This guide is still valid for the current 0.9.6.1 branch 0.9.6.1 also builds with boost 1.64.0 and QT 5.8