Feathercoin daemon and wallet production version 0.17.0.2

[Guide] CPU mining using Linux (Ubuntu)


  • | Tip ShadowEW

    [quote name=“ChristianRiesen” post=“1765” timestamp=“1368092701”]
    I wrote a whole block about it, but I think I add another warning, thanks 🙂
    [/quote]
    There’s many a person out there that won’t read the block text but just look at the italics and code. And just hop, skip and jump past all the ‘boring’ stuff. 😣


  • Regular Member | Tip sheepson

    Thanks! I will add this to the main ‘guide’ topic!


  • Regular Member | Tip ChristianRiesen

    [quote name=“ShadowEW” post=“1767” timestamp=“1368092829”]
    [quote author=ChristianRiesen link=topic=321.msg1765#msg1765 date=1368092701]
    I wrote a whole block about it, but I think I add another warning, thanks 🙂
    [/quote]
    There’s many a person out there that won’t read the block text but just look at the italics and code. And just hop, skip and jump past all the ‘boring’ stuff. 😣
    [/quote]
    I know. I don’t get how people can make anything work that way. I could just make a shellscript they can run and then I have lots of people mining for me 😉


  • | Tip spynappels

    Don’t forget you can use apt-get instead of aptitude if it’s not installed and you don’t want to for some reason.

    Nice guide, Ubuntu is my distro of choice too.


  • Regular Member | Tip HopeStillFlies

    Okay, everything is working manually but when I try doing this:

    [quote]
    chmod a+x /etc/init.d/minerd
    cd /etc/rc2.d/
    ln -s …/init.d/minerd S99minerd[/quote]

    It says:

    [quote]ln: failed to create symbolic link ‘S99minerd’: File exists[/quote]

    Any idea what I need to do in order to get it to launch by itself every time?

    Okay, and weird, last night it was working and showing me a hash rate but now it’s just detecting blocks. All I did was move the computer from one location to another; what’d I do?


  • | Tip jimwalton7

    Install failed. Log at https://dl.dropboxusercontent.com/u/4071418/config.log

    Any suggestions?


  • Regular Member | Tip HopeStillFlies

    [quote name=“jimwalton7” post=“33293” timestamp=“1383609515”]
    Install failed. Log at https://dl.dropboxusercontent.com/u/4071418/config.log

    Any suggestions?
    [/quote]
    Your dropbox is 404’d to boot. Ever figure it out?


  • | Tip fame

    [quote name=“ChristianRiesen” post=“1750” timestamp=“1368090415”]
    [tt]aptitude install make gcc m4 automake libevent-dev zlibc zlib1g-dev libjansson-dev libcurl4-openssl-dev git[/tt]
    [/quote]

    Great guide! I just wanted to point out though that instead of aptitude to install make gcc m4 and automake you can just:

    [tt]apt-get install build-essential libevent-dev zlibc zlib1g-dev libjansson-dev libcurl4-openssl-dev git[/tt]

    build-essential will install all you need for compiling


  • Regular Member | Tip HopeStillFlies

    Quick question for those with the linux knowhow. If you did this:

    [code]To make it start and stop automatically, execute these commands now:

    chmod a+x /etc/init.d/minerd
    cd /etc/rc2.d/
    ln -s …/init.d/minerd S99minerd[/code]

    How do you tell it to NOT start automatically at boot?


  • | Tip Stevenseven77

    First thank you very much for this write up (what is an appropriate FTC tip amount)
    Second I am having a small issue (Linux Ubuntu)
    Everything went very smooth except for the following:
    zlib1g-dev This is a number 1 in front of the g? Or lowercase L? I can’t find this package
    And Theese are my errors
    Checking for gawk… No
    Checking wether to enable maintainer-specific portions of makefiles…no
    Checking wether the C compiler works…no
    Configure error: in ‘/usr/local/cpuminer’:
    Configure: error: c compiler cannot create executables

    UPDATE: working and hashing Yay!!!
    Fix: do the following
    autoconf
    automake
    bison
    build-essential
    flex
    gawk
    libtool

    You should be OK for compiling then.