Feathercoin daemon and wallet production version 0.18.1
Old daemon and wallet version 0.17.0.1

FTCVanity.exe


  • | Tip UKMark

    v1.09

    [b]Changelog:[/b]

    99.9% bug free, I would say 100% but that would be tempting fate.
    Improved initial once only benchmarking configuration script to take an average over 5 iterations of the test, this gives a far more accurate result to enable configuration for system performance differences down to milliseconds.

    …And that’s it really, don’t think I can take this much further now, apart from maybe an auto import key feature, when/if the client becomes more accessible.

    Many thanks to everyone who contributed with feedback and a BIG thanks to Markus1337 for his bug reporting an improvement ideas/suggestions. 😎

    Enjoy! 🙂


  • Regular Member | Tip Markus1337

    [quote name=“UKMark” post=“5554” timestamp=“1369255415”]
    v1.09

    [b]Changelog:[/b]

    99.9% bug free, I would say 100% but that would be tempting fate.
    Improved initial once only benchmarking configuration script to take an average over 5 iterations of the test, this gives a far more accurate result to enable configuration for system performance differences down to milliseconds.

    …And that’s it really, don’t think I can take this much further now, apart from maybe an auto import key feature, when/if the client becomes more accessible.

    Many thanks to everyone who contributed with feedback and a BIG thanks to Markus1337 for his bug reporting an improvement ideas/suggestions. 😎

    Enjoy! 🙂
    [/quote] Very good job you did there Mark! OpenCL (GPU) seems stable for my PC and almost doubled the key/s rate compared to the CPU. Anyone interested it is really worth checking it out 😎


  • Spammer Banned | Tip Kevlar

    I was having some problems with 1.07, but 1.09 seems to be quite awesome.


  • | Tip UKMark

    [quote name=“Kevlar” post=“5882” timestamp=“1369342633”]
    I was having some problems with 1.07, but 1.09 seems to be quite awesome.
    [/quote]

    Brilliant news, thanks for the FB 😎


  • | Tip UKMark

    Looks like v1.10 is just around the corner…

    [img]http://mtgoxlagometer.herobo.com/bug.PNG[/img]

    While this does not affect functionality, its a tad confusing to say the least 😃

    I simply forgot to add the $name variable to the error message box, I will sort and push later! 😎


  • | Tip UKMark

    v1.10 ^^Above minor bug now fixed:

    [img]http://mtgoxlagometer.herobo.com/buggone.PNG[/img]

    That makes a bit more sense now 🙂

    OP installer.exe link updated, I will update source later on today.


  • Regular Member | Tip ghostlander

    If a wallet is encrypted, type in the console before importing a private key:

    [code]walletpassphrase YourPassword Seconds[/code]

    Unlocks the wallet for a number of seconds specified, continue with importprivkey as usual.
    dumpprivkey shows it for a given address, proceed as above for encrypted wallets.


  • | Tip UKMark

    [quote name=“ghostlander” post=“6203” timestamp=“1369430629”]
    If a wallet is encrypted, type in the console before importing a private key:

    [code]walletpassphrase YourPassword Seconds[/code]

    Unlocks the wallet for a number of seconds specified, continue with importprivkey as usual.
    dumpprivkey shows it for a given address, proceed as above for encrypted wallets.
    [/quote]

    Awesome! thanks for this, I don’t suppose you know of way to import into the client (not daemon) via cmd and without setting it up as a server? I just want to fully offer a one app does all tbh without too much user intervention…


  • Regular Member | Tip ghostlander

    Hmm, didn’t try it that way…


  • | Tip UKMark

    [quote name=“ghostlander” post=“6318” timestamp=“1369476277”]
    Hmm, didn’t try it that way…
    [/quote]

    No worries, I have tried various routes and always come up blank on this. 😞

    Anyway I have added your useful info to the OP, thanks again for sharing! 😎


  • Banned | Tip jamesgarfield

    Does this actually work?


  • | Tip UKMark

    [quote name=“jamesgarfield” post=“6557” timestamp=“1369538441”]
    Does this actually work?
    [/quote]

    It works for me and others…If you are having issues then post below…


  • Regular Member | Tip ghostlander

    [b]“This installation requires Windows Vista/7/8. Installation cannot continue.”[/b]

    That sucks very much.


  • | Tip UKMark

    [quote name=“ghostlander” post=“8375” timestamp=“1370015942”]
    [b]“This installation requires Windows Vista/7/8. Installation cannot continue.”[/b]

    That sucks very much.
    [/quote]

    It was never tested on XP so I removed it from the installer configuration, but you are welcome to try:

    Let me know…

    Edit: [Link Removed] Doesn’t work on XP or 2003


  • Regular Member | Tip ghostlander

    I’m on 2003 R2 x64, though XP is not much different when it comes to desktop use. The installation is quick and easy now.

    [img]http://img254.imageshack.us/img254/8084/ftcvanity.png[/img]

    I guess there must be some kind of logo. In general, works fine.

    [b]“ERROR!! FALSE POSITIVE DETECTED!!”[/b]

    Yep, me knows how to screw up software 🙂


  • | Tip UKMark

    I take it I was right with just allowing Vista, 7 & 8 then 😉
    Weird how the logo won’t display, as the Background and Logo are both base64 :-\
    Oh well thanks for testing, looks like it will have to suck though. 🙂


  • Regular Member | Tip ghostlander

    Well, it generates addresses/keys on my 2003 actually. The client validates them with no problem. I’ve catched a few false positives while playing with some weird patterns such as 71/72/73. If you fix the logo thing, it’s all right.


  • | Tip UKMark

    [quote name=“ghostlander” post=“8396” timestamp=“1370025438”]
    Well, it generates addresses/keys on my 2003 actually. The client validates them with no problem. I’ve catched a few false positives while playing with some weird patterns such as 71/72/73. If you fix the logo thing, it’s all right.
    [/quote]

    Arrr yeah 7’s they are a bit hit and miss 🙂

    OK, I [i]think[/i] it may be a .png problem as that is the only noticiable difference between both images (BG & Logo), so I have updated the Logo to a gif - Base64 so it is now exactly the same as the Matrix background.
    Other than that I am totally lost as I don’t have the means to debug this solo 😞

    Anyway, fingers crossed:

    [url=https://docs.google.com/file/d/0B5rwxlWy7MtLT2RwMHJncTZsR1U/edit?usp=sharing]FTCVanity_v1.10_XP_Test_v2.exe
    [/url]
    Let me know…


  • Regular Member | Tip ghostlander

    No difference, must be something else. Although you can simply remove it for the XP/2003 build.

    [img]http://img841.imageshack.us/img841/2586/ftcvanity2.png[/img]

    I guess that’s because I’m using 120 DPI fonts while most people are comfortable with 96 DPI ones, but you can add some bottom space to the Settings window anyway.


  • | Tip UKMark

    Thanks for FB 😎

    OK one last try with the logo before I remove it completely, I have re-sized the settings screen so should be OK now…

    [url=https://docs.google.com/file/d/0B5rwxlWy7MtLZ2FLZnB2MFp2bzA/edit?usp=sharing]FTCVanity_v1.10_XP_Test_v3.exe[/url]


Log in to reply