Feathercoin daemon and wallet production version 0.16.3
Attention!!!! If you are running a Feathercoin version other than 0.16.3 upgrade imediately to 0.16.3 . It contains an important bug fix

[Support] Mode of Failure Analysis. Part 2 - Faults, Causes and Solutions


  • Moderators | Tip wrapper

    This Mode of Failure Analysis only applies to the Feathercoind (daemon or service) and Feathercoin-qt wallet developments from v0.7 to 0.85.

    These are just notes, to help support the up coming Feathercoin 0.8.5 release and can be sorted into priority order and refined into a better Feathercoin Support FAQ later.

    I have split the FMECA to Part 2 - because there is a forum post size limit.

    I have also added some extra questions, where a Bitcoin or Litcoin development could potentially be ported to Feathercoin. e.g. Should FeathercoinOMG be developed? or “What is an escrow service?”

    Wallet Bitcoin-QT Appcrash - Windows 7 64 Bits

    Unsolved -redownload and install new client

    I tried to MANUALLY create the Receive address!.

    You can’t do that.

    Check if an incoming transaction is coming into a bitcoin public address

    There’s a build of bitcoind/bitcoin-qt with experimental features called “bitcoinomg” (or something like that). that build contains watch only address feature, which looks like what you you need.

    Should Feathercoin develop FeathercoinOMG?

    How do I build my own exchange web? I am a PHP/Mysql web developer

    I think there is an open source project for an online exchange Intersango?.

    Check out Bitcoin-Central on github, but the code is pretty old.

    [url]=https://github.com/davout/bitcoin-central]https://github.com/davout/bitcoin-central[url]

    If you are asking, then you shouldn’t be creating it. Exchanges are very costly, everything is zero critical. Also trading engines shouldn’t be in php, they should be in higher language

    There is no correctly working bitcoind for Debian?

    feathercoind can be installed from from the pre-compiled install packages, is working for Debian 7.0

    Install on Debian Process
    [url]=https://js.gg/installing-bitcoind-on-debian-wheezy-7/]https://js.gg/installing-bitcoind-on-debian-wheezy-7/[url]

    Do it from scratch, Just use 0.8.5 Instead of 0.8.1 which is in article.

    Ok, I found out that the reason of failed compilation was broken version of libboost1.49-dev package in stable release of Debian.
    I renewed version of the library and have the bitcoind successfully compiled now.
    [url]=https://github.com/bitcoin/bitcoin/issues/2726]https://github.com/bitcoin/bitcoin/issues/2726[url]
    erraneous InvalidChainFound messages

    Try a start with bitcoin-qt -reindex -par=1 on the command line
    To exclude the possibility that the Debian patches were the cause, could you try the same thing with the released bitcoind binaries on sourceforge/ github?
    Does this mean we may have a problem with the parallel verification code?
    This is a problem with the 32 Bit version, work ok 64 bit.
    Not resolved

    When did Transaction fees become mandatory?

    So now I have a small balance I can never remove from a wallet? Its not worth less but I can’t transfer it.

    Fees have been mandatory for a very long time except for ‘priority’ transactions when block is < 27000 bytes these still exist.

    Minimum fees were introduced to prevent dust coin DDoS attacks on thje network.

    You can pay an addition fee, which is prioritised in the network, by accesing, setting options main.

    Feathercoin and Litecoin have adjusted their fess after community agreement.

    The level an reason for Fees have been adjusted by the consensous, in order to align fees with value.

    There have been discusions on fees, how miners are effected by fees, how are miners compensated when the block payments reduce?. It has been argued that a very low proportional fee would be fairer and allow small transactions, for instance.
    [url]=https://en.bitcoin.it/wiki/Transaction_fees]https://en.bitcoin.it/wiki/Transaction_fees[url]

    How to create an address using bitcoind or Feathercoind?

    bitcoind help
    bitcoind getnewaddress

    Also in the wallet, Help, Debug, console tab, type help, or getnewaddress

    What is an escrow service?

    Android Wallet to make the payment there is an issue with scanning the QR code.

    If there is a scan Qt code problem :

    You can type the FTC address in manually.

    Where can I compare GPU mining performance for scrypt?

    [url]=https://litecoin.info/Mining_hardware_comparison]https://litecoin.info/Mining_hardware_comparison[url]

    Is there a way to listen to new/unconfirmed transactions with the litecoin daemon ?

    getblocktemplate to retrieve block to mine and hence current unconfirmed transactions

    MAC OSX 10 compilation errors, can’t compile from source
    litecoinpatch98
    osx 10.9 changed the default stdlib to libc++. You may need to compile with libstdc++ to prevent some errors. At the same time, boost should be compiled use a cxxflag ‘-stdlib=libstdc++’

    @imbolo The Mac build system is MacOS X 10.6.8 with Xcode 3.2.6 which is necessary to make binaries that can run on all versions of Mac from 10.6 through 10.9.

    Got it. From 10.6 to 10.8, the -stdlib’s value is libstdc++ by default. I can only test it under 10.8 and 10.9 now. May that line can be commented now until it was tested under 10.6

    There is a problem with one of the DNS seeds

    That seed is down now, it is probably due to maintenance. There are other seeds.

    Windows version of software in not up to date.

    With all the development recently, how do I know there is a new version of feathercoin-Qt.exe?

    A message can be sent over the coin network already, that a new version is available. There have been previous updates to ensure coin network messages don’t clash. There is a message channel system built into the code. It would be good to test that over the network, what about. Announcing Feathercoin-Qt RC2? over the network message as a test.

    There could be an enhancement to the wallet client with a link to Feathercoins download page or check for new version, for Windows.

    The vast majority of upgrades will be backwardly compatible. There are very few “hard forks” where clients not mining to the new protocol could form their own Blockchain. This is because, it needs to be an emergency to want to do that.

    In the future it will be possible to do hard forks, as long as there is ample warning that everyone must upgrade and after the upgrade old incompatible clients are “messaged” over the network.

    How much are Feathercoins worth

    Mathematically,

    If BTC = 100
    LTC = 20
    FTC = 5

    However, if FTC has 10 times as many users, then FTC = 50

    Because it would make Feathercoins more scarce.

    Why is there no Help in Feathercoin-Qt Wallet?.

    This is an excellent opportunity to contribute to the community. You don’t need to be programmer to provide content for a help file. The work can then be passed upstream for use on other coin clients.

    Help I restored a backup and it is empty of coins

    Are you on Linux? Yes. check the type case is correct, wallet.dat, not Wallet.dat when you renamed your restored backup.
    In Linux, file viewer, Press ALtDot and check in the folder ./feathercoin to see if you have 2 wallets.

    I searched google for found a FTC Wallet on some web site. It won’t sync?

    That site contains incorrect version of the Feathercoin software. You must run the correct version to join the network.

    Old versions of Feathercoin-Qt and Feathercoind - do not recognise checks and other issues have been fixed. The upgrade then must be forced by deprecating the old version.

    This is only done rarely, as it can cause a fork of the Blockchain, which means embarrassing emergency recovery work and some miners loosing out as one of the duplicate chain will be orphaned…

    Inform Feathercoin Discussion thread or Support of the Bad Feathercoin download link.

    To remain safe, you are advised, only download from this site Feathercoin.com.

    Only download from Github, if you know Github well.


  • Moderators | Tip Wellenreiter

    feathercoind from the pre-compiled install packages also is working for Debian 7.0


  • Moderators | Tip wrapper

    [quote name=“Wellenreiter” post=“42738” timestamp=“1386713706”]
    feathercoind from the pre-compiled install packages also is working for Debian 7.0
    [/quote]

    I put that in - Great. Have you got some links handy to those packages? I’ll update then delete dross…