Feathercoin daemon and wallet production version 0.17.0.2

[Solved] Feathercoins have dissapeared


  • administrators | Tip uncle_muddy

    Sounds to me like the wallet.dat that had your 6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV address in it has some how managed to get over written. I’m pretty certain a Windows 8.0 --> 8.1 upgrade would not cause this but will build a dev environment a little later today and see what happens if I have time.

    I’m going to as some questions, I don’t think your stupid I just want to rule out the simple things in life because I am a very simple person 🙂

    ​Did you change the user account/name you where logging onto the laptop with?

    Did you reinstall the wallet after you generated the 6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV address

    Have you done a simple search of the hard disk for wallet.* (not wallet.dat) and can you post the results?

    UM


  • | Tip Sebastiaan

    Good Morning Sebastiaan, welcome here again.

    If your wallet are completed synced and no coins are into, please reach this condition :

    • Verify that your wallet completed sync with network
    • Verify that the 6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV address are into your wallet (the address is into the wallet.dat file, place the correct wallet.dat into the folder)

    Only when you reached these conditions, please follow these steps :

    • start feathercoin
    • open a console window in feathercoin (Debug-> console)
    • type **dumpprivkey **6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV
    • copy/note/write down the response, which is your private key for that address

    (DO NOT POST PUBLIC YOUR PRIVATE KEY, KEEP IT SAFE AND SECRET)

    Let me know when you are done these steps.

    No joy, the address does not appear in the wallet and the console returns:

    Private key for address 6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV is not known (code -4)

    Sounds to me like the wallet.dat that had your 6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV address in it has some how managed to get over written. I’m pretty certain a Windows 8.0 --> 8.1 upgrade would not cause this but will build a dev environment a little later today and see what happens if I have time.

    I’m going to as some questions, I don’t think your stupid I just want to rule out the simple things in life because I am a very simple person 🙂

    No problem

    ​Did you change the user account/name you where logging onto the laptop with?

    No

    Did you reinstall the wallet after you generated the 6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV address

    No

    Have you done a simple search of the hard disk for wallet.* (not wallet.dat) and can you post the results?

    The search is currently running


  • Regular Member | Tip xonar

    Sebastiaan, No wallet with the 6vC7eRfrmeFhPQRzJidicDfjjN7Saii1VV address, no coins.

    Let me know… good luck

    (Recycle Bin ??)


  • | Tip Sebastiaan

    Search of the C drive returns two files:

    the wallet.dat in the user/appdata/roaming/feathercoin folder and the backup I made of this file in my google drive folder. They are the same file so restoring the wallet.dat from my google drive is not goin to make a difference here.

    Looks like the wallet.dat file dissapeared somewhere yesterday as I was doing the windows 8.1 upgrade. I’m running a Mcafee antivirus and firewall which came with this laptop, and was here most of the time, so I cannot assume foul play at this stage. (none of my colleques at work are to clued up on cryptocoins to heist my wallet anyway…

    What i am wondering about: I did use ccleaner yesterday after the upgrade to clean out internet cache and windows tmp files. I also set windows environment variables to the same appdata folder. so it could be possible that ccleaner erased files from the folder. Unlikely though since some of the files in this folder are from yesterday morning. Ill run cc cleaner again to c what happens. Its probalbly a red herring here…

    sigh…

    :-\


  • | Tip Sebastiaan

    Ok so I ran ccleaner and restarted the wallet, the blockchain information has now dissapeared and the wallet has to start syncing all over again. It’s currently 51 weeks behind. Im getting very worried that i must have messed this one up myself…

    😞

    Will be with a student in the flightsim for the next hour and check back after that!


  • | Tip kris_davison

    Sorry to hear you are having problems.

    Well you may still be able to get the wallet back as I think windows would have done a system restore point before the upgrade. Hopefully this would have your old wallet intact.

    It may be an option.

    Or maybe if you can recover the deleted files maybe in recycle bin?


  • administrators | Tip MrWyrm

    You could try Piriform Recuva. Run it, get rid of the wizard so you are in advanced mode and do a search for *.dat.


  • administrators | Tip MrWyrm

    I’ve had a lovely day. Random act of kindness. 20 FTC sent to the address in your signature, Sebastiaan.


  • Regular Member | Tip xonar

    Some news Sebastiaan ?


  • administrators | Tip MrWyrm

    Hopefully, this will help. I’m also on 8.1. I’ve experienced similar today with another coin’s QT. When I installed QT and upon completing the install, letting the program run from the ‘run now’ tickbox, it presents me with a different address to if I run from the program files icon (and a different level of synchronised). Upon closing the program and relaunching it my address had changed, I thought I’d done something silly, but reinstalling the program and following the tick box presented me with the lost address again. So there are two copies of the wallet, and it would seem one is only accessible when launching after installation. Now, I’m wondering, if you run as administrator, as I had to when installing, does it save the wallet into the elevated account’s roaming appdata? And could this possibly be your issue?

    *edit* yes it does, running QT clients from the ‘run as administrator’, lands you in the administrator accounts wallet. I guess that makes sense from a logical point of view, but I’ve not seen it mentioned anywhere before.