Feathercoin daemon and wallet production version 0.17.0.1

Solo mining setup


  • Regular Member | Tip jarrettph

    So I set up Feathercoin and CGminer 3.7.2 but I keep getting “JSON inval data” and “No suitable long-poll found for http://...*:9337”. Then after a couple minutes it closes.

    My feathercoin.conf is:
    server=1
    rpcuser=user
    rpcpassword=password
    rpcallowip=...*
    rpcport=9337

    My cgminer bat file is:
    color 2
    setx GPU_MAX_ALLOC_PERCENT 100
    cgminer --scrypt --shaders 2048 --intensity 13 --auto-gpu --auto-fan -o ...*:9337 -u user -p password

    Not sure what I’m doing wrong. Can someone help me please?


  • Moderators | Tip Wellenreiter

    You can try to run cgminer in text only mode and enable debug, so you get additional data about the problem.
    If the miner is not running on the same system as the wallet or feathercoind the connection also may be blocked by a firewall or iptables configuration.

    The feathercoind log file also may give a hint, if the connection request from the miner arrives at the feathercoind node and why the connection is not accepted.
    The feathercoind log is

    • for linux:
      • ~/.feathercoin/debug.log
    • for windows:
      • $APPDATA$\feathercoind\debug.log

  • administrators | Tip uncle_muddy

    @jarrettph said:

    cgminer --scrypt --shaders 2048 --intensity 13 --auto-gpu --auto-fan -o ...*:9337 -u user -p password

    Should this not be --neoscrypt?

    Been a long time since I have set a miner up and don’t have anything to hand to take a look for you, but maybe worth a shot

    UM


  • Moderators | Tip Wellenreiter

    Good catch, Muddy 🙂

    I should read a bit more, before suggesting complicated trouble shooting 😉


  • Regular Member | Tip jarrettph

    Ok I read a tutorial that said it was --scrypt but I will try that. Also how do I enable debug mode? Is there a command I put in the bat file or something else entirely? Thanks guys for the help!


  • Regular Member | Tip jarrettph

    Ok I set it to --neoscrypt and now it just blinks off instantly when I run it.


  • Moderators | Tip Wellenreiter

    @jarrettph
    The option to enable debug is –debug or as alternative -D

    I suggest to use the -T option in combination with the -D. It makes the debug output more readable

    cgminer --help gives you all available options