Supported Feathercoin client versions: Current production Version: 0.16.1.

Old Production Version: 0.16

Info: If you have problems to post, create one post in the ‘newbies’ category and try again. If you have further problems, find support under Guides

What version of P2pool software to use with Feathercoin Neoscrypt?


  • Moderators

    I have released a new Version of p2pool software. There was one bug in the version selection algorithm

    P2pool operators please pull the latest code from Github:
    https://github.com/wellenreiter01/p2pool-neoscrypt


  • Moderators

    This post is deleted!

  • Moderators

    There are 3 of the p2pool nodes still on the old version of code.

    These pool nodes didn’t find a block for 3 days now and are the cause, that there are two smaller p2pool clouds instead of one bigger cloud, which would be able to find blocks faster.

    I strongly recommend to update to the latest code version.

    The ‘old’ pools are :


  • Moderators

    I’ve had a problem I’ve been investigating and we’ve been discussing with NSGminer not returning to my preferred p2pool on fail over when a pool goes down.

    @Ghostlander @Wellenreiter .

    Although I have set a “fully compatible” p2pool and it still happens, it does look like NSGminer reports p2pool I was just on as Dead when it tries to return from a “non compatible” p2pool version.

    If I restart NSGminer it finds my preferred pool, i.e. it isn’t dead…

    Notes:
    It is slightly funny I get stuck on kosmoplovci.org which should be most compatible (needs check)

    I have got list of pools, consider possibilities, push changes to rouge pool’s github to fix compatibility? fix in NSGminer (not going back to a higher version pool after fail over, because enabled fails test?)

    46.4.0.101:19327
    175.33.59.90:19327
    http://www.kosmoplovci.org:19327/static/
    104.236.34.9:19327


  • Moderators

    How long did you wait for yoir miner to switch back?


  • Moderators

    @Wellenreiter said:

    How long did you wait for your miner to switch back?

    It’s like that every morning, at the moment, checking p2pool charts > 7 Hours last night, for instance i.e. It never goes back, as pools reports all dead, when they aren’t.

    It is the same on the two mining PCs, one is Ubuntu14.04 and the other 15.10.

    Note : It may be to do with changed stratum settings? The return to main.c is performed in NSGminer api.c

    This is the check if a pool is dead :
    api.c Line 1445
    status2str(enum alive status)

    api.c

    static const char *status2str(enum alive status)
    {
    switch (status) {
    case LIFE_WELL:
    return ALIVE;
    case LIFE_SICK:
    return SICK;
    case LIFE_DEAD:
    return DEAD;
    case LIFE_NOSTART:
    return NOSTART;
    case LIFE_INIT:
    case LIFE_INIT2:
    return INIT;
    case LIFE_WAIT:
    return WAIT;
    default:
    return UNKNOWN;
    }
    }

    The test seems to be don here : line 980 of driver-opencl.c

    driver-opencl.c
    Showing the top two matches. Last indexed on 30 Mar.
    switch (cgpu->status) {
    default:
    case LIFE_WELL:
    wlog(“ALIVE”);
    break;
    case LIFE_SICK:
    if (cgpu->status != LIFE_WELL) {
    wlogprint(“Must restart device before enabling it”);
    goto retry;
    }
    applog(LOG_DEBUG, “Pushing ping to thread %d”, thr->id);


  • Moderators

    It’s interesting, that I didn’t notice that problem. My cudaminer can use one pool at a time only, so it simply waits and and tries every 30 seconds to connect and get work. It seems to return to work as soon as the pool is back