Feathercoin daemon and wallet production version 0.19.1
Old daemon and wallet version 0.18.3

[Guide] Build FeathercoinD & Feathercoin-QT v0.9.6.1 on Ubuntu

  • Moderators | Tip Wellenreiter

    Another remark
    As far as I know, --disable-shared forced a static build, where all libraries are complied into the binary, what increases the size of the binary and overall memory usage.
    For me the compile works without that parameter,too

  • Moderators | Tip AcidD

    @wrapper - Did you manage to get 15.10 working ? I’m wondering if I should give this a shot and write another guide or maybe you guys can give me something else to do that’s a better use of my time ?

    let me know!

  • Moderators | Tip wrapper

    @aciddude said:
    @wrapper - Did you manage to get 15.10 working ? I’m wondering if I should give this a shot and write another guide or maybe you guys can give me something else to do that’s a better use of my time ?

    let me know!

    If you want to see if you can get the 15.10 compile / test finished, please go ahead.

    Unfortunately, I didn’t use a Virtual box and sort of went bit exotic on the dependency checking and crashed out my 15.10 system.

    Basically, don’t ever install libqt5-gles-dev, as when you remove it, Kubuntu does not reinstall the kde dependency, libqt5-gles it removed and deleted all the kde dependencies for my desktop.

    I’ve ended installing 16.04, which didn’t upgrade well, possibly due to multiple sources in software sources list, so I ended up reinstalling / upgrading. It didn’t update lots of programs, so a bit more work to get my home system back up to speed.

    As that happened, also had the cooling backing plate failed on my NSGminer R9 290 test computer. I’ve had to search the house for a spare I know I’ve kept for 5 years. So I’ve had to reinstall that, luckily had some thermal paste to re-seat the CPU.

  • Moderators | Tip wrapper

    @aciddude said:

    This needs a bit of QA though…I don’t think BitMessage worked…everytime I clicked it, nothing happened…or does that have to wait for a full blockchain sync ?

    @Lizhi added Bitmessage feature

    With regard to Bitmessage, I’m just researching some of that, to fix my install with 16.04.

    Note : I’ve just tried Bitmessage and failed : so it might be python 2 not installed by default in 16.04 -

    Your system may be attempting to run PyBitmessage with python 3. In this case, run python2 ~/PyBitmessage/src/bitmessagemain.py

    Bitmessage requires PyQt and openssl to run

    Bitmessage dependancies :
    sudo apt-get install python openssl git python-qt4

    Additionally on 16.04 :
    sudo apt install libmessaging-menu-dev

    Pull latest Bitmessage updates from :

    Bitmessage has been updated quite a bit if anyone wants to test it :


    Note : Bitmessage upgrade - User interface for Bitcoin payments issue #841

  • Moderators | Tip Wellenreiter


    I’ve managed to compile for 15.10 and 16.04.
    The binary packages are just build and will be available this evening at

    Remark: 0.9.3.x gui does not compile with qt4. You need to specify configure --with-gui=qt5

  • Regular Member | Tip UnklAdM

    Good information. Thanks everyone!

    • UnklAdM

  • Moderators | Tip Wellenreiter

    Forgot to mention: I also patched rpcrawtransaction.cpp to detect boost 1.58, so no modification of the code is needed to compile for Ubuntu 15.10 and 16.04

  • Moderators | Tip wrapper

    Re : Fixing rcprawtransaction.cpp transaction bug squared .

    @Wellenreiter I want to give you more kudos +1000 🙂

  • Moderators | Tip Wellenreiter

    It’s currently on only, as this is the latest release version.

  • | Tip looarn


    Just to say thanks a bunch @aciddude !

    I got a node running on a debian.

    I just need to add this dependency : apt-get install -y pkg-config

    Actually syncing. ^^

  • Moderators | Tip AcidD

    Hi All,

    Ubuntu has recently changed a few things.

    building Feathercoin 0.9.6 - you might come across this error:

    libbitcoinqt.a(libbitcoinqt_a-snapwidget.o): In function SnapWidget::on_snapButton_clicked()': [ 743s] /usr/src/packages/BUILD/src/qt/snapwidget.cpp:72: undefined reference tozxing::String::getTextabi:cxx11 const’

    To fix, you need to rebuild zxing like this:

    mkdir zxing && cd zxing 
    git clone https://github.com/glassechidna/zxing-cpp.git
    cd zxing-cpp/
    mkdir build
    cd build/
    export CXXFLAGS="-fPIC"
    make && sudo make install

  • Moderators | Tip Wellenreiter

    That’s the solution to one of the little problems I have while creating the Linux installation packages 🙂

    Many thanks