Feathercoin daemon and wallet production version 0.17.0.2

[Dev] Feathercoin 0.9.6.2 * Maintenance fix, build & upgrade issues notes.


  • Moderators | Tip wrapper

    Notes : Minimum fee issue / review

    Review src/util.h 0.9.x

     static const int64_t COIN = 100000000;
    

    https://github.com/FeatherCoin/Feathercoin/blob/0.9.6/src/main.h

    nBaseFee is the value you configure. In 0.9 default is 1000000
    
    int64_t nMinFee = (1 + (int64_t)nBytes / 1000) * nBaseFee
    

    Review main.cpp main.h 0.8.x

    https://github.com/FeatherCoin/Feathercoin/blob/master-0.8/src/main.h

      /** Dust Hard Limit, ignored as wallet inputs (mininput default) */
     static const int64 DUST_HARD_LIMIT = 1000; // 0.00001 FTC mininput
    
     /** Dust Soft Limit, allowed with additional fee per output */
    static const int64 DUST_SOFT_LIMIT = 100000; // 0.001 FTC
    

    Litcoin related issues and updates (over Bitcoin)

    Minimum Transaction Fee review

    https://github.com/litecoin-project/litecoin/commit/3ce57329263cd347ada29172947b23dfc787e898
    https://github.com/litecoin-project/litecoin/commit/378ff026d0fc5205b2e15d2c2b05534d013ef5c5
    https://github.com/litecoin-project/litecoin/commits/0.8?after=9cffb23c2d48d47bb67df78ea1164738b41e8c9d+69
    https://github.com/litecoin-project/litecoin/commit/f80351c3215014935c5836f7d90cc21af5fc0cdf
    https://github.com/litecoin-project/litecoin/commit/72b4e39c092b03abc5495b908f671b2ca8fe03cd
    https://github.com/litecoin-project/litecoin/commit/def3c9e53b20815c8eef0aef7c9315cdd4a889c6

    https://github.com/litecoin-project/litecoin/commit/70313dd1e7518d410dac30db4906aac4846520a7


  • Moderators | Tip wrapper

    https://litecoin.info/Transaction_fees

    limitfreerelay 15,000 (Bytes)

    Limit of free transactions the client will relay to other nodes per minute

    mintxfee 0.001 (LTC)

    Minimum fee per KB for non free transactions (creating)

    minrelaytxfee 0.001 (LTC)

    Minimum fee per KB for non free transactions (relaying)

    mininput 0.00001 (LTC)

    Wallet ignores smaller inputs

    DUST_THRESHOLD 0.001 (LTC)

    Minimum output to avoid an additional mintxfee charge per smaller output

    blockmaxsize 1,000,000 (Bytes)

    Maximum block size

    blockminsize 0 (Bytes)

    Minimum block size

    blockprioritysize 17,000 (Bytes)

    Size of the block reserved for highest-priority transactions (regardless the fee)

    maxhighprioritytxsize 12,000 (Bytes)

    Maximum size of a transaction to be eligible for highest-priority


  • Moderators | Tip wrapper

    Re : How should the FTC fees been set?

    LTC was 4 times Faster than BTC, so fee level need to be 1/4 BTC to be proportional.

    FTC had 4 times the amount of coins than LTC, so FTC fee need to be 1/16 of BTC value, or 1/4 LTC value.

    It looks like LTC settled on 1/10 for ease of calculation and make fees lower than BTC.

    In 0.6.x and 0.7.x FTC settled on 1/20 which make our fees slightly less than LTC, and is easier to code.

    Our dust level needs to be reduced by same level (which has been done?)


  • Moderators | Tip wrapper

    Re : neoscrypt version. I was checking neoscrypt version as @Ghostlander had mentioned somewhere it may be out of date. / where to cherry pick from list

    add Implemented ACP and neoscrypt

    https://github.com/FeatherCoin/Feathercoin/commit/c8ca4c906144910c62acd34e23a4ed624c0fbf7d

    https://github.com/ghostlander/nsgminer

    ToDo :

    add neoscrypt issue to 0.11 done
    Create the where to cherry pick from list


  • Moderators | Tip wrapper


  • Moderators | Tip wrapper

    Testing the 0.9.6.2 updated GNU/ Linux Ubuntu example instructions, ready to pull into 0.11.2

    Failed to build with error :

    /usr/include/x86_64-linux-gnu/qt5/QtCore/qglobal.h:1087:4:
    error: #error "You must build your code with position independent code if Qt was built with -reduce-relocations. " “Compile your code with -fPIC (-fPIE is not enough).”

    # error "You must build your code with position independent code if Qt was built with -reduce-relocations. "\

    Tried : Adding -fPIC to CFAGS in makefile

    git checkout 0.11.2
    
    export CXXFLAGS="$CXXFLAGS -fPIC"
    make clean
    ./autogen.sh
    autoupdate
    
    ./configure --with-gui=qt5 --enable-tests=no  --with-incompatible-bdb --enable-upnp-default --with-qrcode=yes  --disable-hardening --enable-shared
        
    make
    

    Gives error :
    CXX qt/qt_libbitcoinqt_a-addressbookpage.o
    qt/addressbookpage.cpp:32:26: fatal error: qrcodedialog.h: No such file or directory
    #include “qrcodedialog.h”

    Someone else fixing it :
    https://github.com/ctrlaltca/Cockatrice/commit/9cfb09cd5b25a01fb142d425ba70b77b89f65a09
    https://github.com/Civil/cantata/commit/9a6d5464376d48cc4c4e37c37459bc8b8aa74ba1


  • Moderators | Tip wrapper

    After adding missing files / updating configure.ac :

    src/qt/qrcodedialog.h and qrcodedialog.cpp

    Compile fails at :

    In file included from qt/addressbookpage.cpp:32:0:
    qt/qrcodedialog.h:22:9: error: expected ‘:’ before ‘slots’
    private slots:

    https://stackoverflow.com/questions/20185423/qt-cmake-missing-before-identifier-slots

    Tried adding missing file : feathercoin.qrc

    Created list of files Not in version 0.11.2 but in version 0.9.6.2 in ~/projects/Feathercoin :

    diff -r ~/projects/Feathercoin ~/Feathercoin | grep ~/projects/Feathercoin > difference2.txt


  • Moderators | Tip wrapper

    Missing / changed files from Feathercoin 0.11 version compared to 0.9.6.2:

    Results of synopsis of missing files / difference show :

    Missing functionality.
    Nameview
    Stealth coins
    Coinector
    Shapeshift

    Missing Icon Upgrade
    Updated Translation files
    Updated auto unit tests

    Detail of the differences - using difference2.txt

    https://github.com/wrapperband/FTC-Wallet-Layout-Examples/blob/master/Develpment/difference2.txt

    Two directories were compared using diff command :

    diff -r ~/projects/Feathercoin ~/Feathercoin  | grep ~/projects/Feathercoin   > difference2.txt
    
    diff -r ~/projects/Feathercoin ~/Feathercoin  | grep ~/projects/Feathercoin | awk '{print $4}'  > difference3.txt
    

    A number of files in these directories :
    Only in : ~/projects/Feathercoin/contrib/
    Only in ~/projects/Feathercoin/doc/
    Only in ~/projects/Feathercoin/qa/
    Only in ~/projects/Feathercoin/share/

    These files missing:
    Only in ~/projects/Feathercoin/src: allocators.cpp
    Only in ~/projects/Feathercoin/src: allocators.h
    Only in ~/projects/Feathercoin/src: auxpow.cpp
    Only in ~/projects/Feathercoin/src: auxpow.h
    Only in ~/projects/Feathercoin/src: base40.h
    Only in ~/projects/Feathercoin/src: bitcoin-config.h

    Only in ~/projects/Feathercoin/src: core.cpp
    Only in ~/projects/Feathercoin/src: core.h
    Only in ~/projects/Feathercoin/src: crypter.cpp
    Only in ~/projects/Feathercoin/src: crypter.h
    Only in ~/projects/Feathercoin/src: db.cpp
    Only in ~/projects/Feathercoin/src: db.h
    Only in ~/projects/Feathercoin/src: feathercoin-cli.cpp
    Only in ~/projects/Feathercoin/src: feathercoin-cli-res.rc
    Only in ~/projects/Feathercoin/src: feathercoind.cpp
    Only in ~/projects/Feathercoin/src: feathercoind-res.rc

    Only in ~/projects/Feathercoin/src/json: json_spirit_reader.cpp
    Only in ~/projects/Feathercoin/src/json: json_spirit_value.cpp
    Only in ~/projects/Feathercoin/src/json: json_spirit_writer.cpp
    Only in ~/projects/Feathercoin/src/json: LICENSE.txt

    Only in ~/projects/Feathercoin/src/leveldb: AUTHORS
    Only in ~/projects/Feathercoin/src/leveldb: NEWS
    Only in ~/projects/Feathercoin/src/leveldb/port: README
    Only in ~/projects/Feathercoin/src/leveldb: README

    Only in ~/projects/Feathercoin/src/obj: .gitignore
    Only in ~/projects/Feathercoin/src: obj-test

    Only in ~/projects/Feathercoin/src/qt: bitcoinstrings.cpp
    Only in ~/projects/Feathercoin/src/qt: coinnectordialog.cpp
    Only in ~/projects/Feathercoin/src/qt: coinnectordialog.h

    Only in ~/projects/Feathercoin/src/qt/forms: aboutdialog.ui
    Only in ~/projects/Feathercoin/src/qt/forms: coinnectordialog.ui
    Only in ~/projects/Feathercoin/src/qt/forms: opennamedialog.ui
    Only in ~/projects/Feathercoin/src/qt/forms: shiftdialog.ui
    Only in ~/projects/Feathercoin/src/qt/locale: bitcoin_de_AT.ts
    Only in ~/projects/Feathercoin/src/qt: Makefile.am
    Only in ~/projects/Feathercoin/src/qt: monitoreddatamapper.cpp
    Only in ~/projects/Feathercoin/src/qt: monitoreddatamapper.h
    Only in ~/projects/Feathercoin/src/qt: shiftdialog.cpp
    Only in ~/projects/Feathercoin/src/qt: shiftdialog.h

    Only in ~/projects/Feathercoin/src/qt/res: feathercoin-qt-res.rc
    Only in ~/projects/Feathercoin/src/qt/res: fonts
    Moved?
    Only in ~/projects/Feathercoin/src: rpcdump.cpp
    Only in ~/projects/Feathercoin/src: rpcwallet.cpp
    Only in ~/projects/Feathercoin/src: script.cpp
    Only in ~/projects/Feathercoin/src: script.h
    Only in ~/projects/Feathercoin/src: stealth.cpp
    Only in ~/projects/Feathercoin/src: stealth.h
    Only in ~/projects/Feathercoin/src: version.cpp
    Only in ~/projects/Feathercoin/src: wallet.cpp
    Only in ~/projects/Feathercoin/src: walletdb.cpp
    Only in ~/projects/Feathercoin/src: walletdb.h
    Only in ~/projects/Feathercoin/src: wallet.h

    Images and icons
    Only in ~/projects/Feathercoin/src/qt/res: feathercoin-qt-res.rc
    Only in ~/projects/Feathercoin/src/qt/res: fonts

    Binary files ~/projects/Feathercoin/src/qt/res/icons/bitcoin.icns and ~/Feathercoin/src/qt/res/icons/bitcoin.icns differ
    Binary files ~/projects/Feathercoin/src/qt/res/icons/bitcoin.png and ~/Feathercoin/src/qt/res/icons/bitcoin.png differ

    Only in ~/projects/Feathercoin/src/qt/res/icons: bitcoin_testnet.ico
    Only in ~/projects/Feathercoin/src/qt/res/icons: bitcoin_testnet.png
    Only in ~/projects/Feathercoin/src/qt/res/icons: coinnector.png
    Only in ~/projects/Feathercoin/src/qt/res/icons: shapeshift.png
    Only in ~/projects/Feathercoin/src/qt/res/icons: toolbar_testnet.png
    Only in ~/projects/Feathercoin/src/qt/res/images: about.1.png
    Only in ~/projects/Feathercoin/src/qt/res/images: about_bitcoin.png

    Binary files ~/projects/Feathercoin/src/qt/res/images/about.png and ~/Feathercoin/src/qt/res/images/about.png differ

    Only in ~/projects/Feathercoin/src/qt/res/images: coinnector.png
    Only in ~/projects/Feathercoin/src/qt/res/images: LOGO_b.png
    Only in ~/projects/Feathercoin/src/qt/res/images: LOGO_b_sm.png
    Only in ~/projects/Feathercoin/src/qt/res/images: LOGO_dg.png
    Only in ~/projects/Feathercoin/src/qt/res/images: LOGO_g.png
    Only in ~/projects/Feathercoin/src/qt/res/images: LOGO_g_sm.png

    Only in ~/projects/Feathercoin/src/qt/res/images: LOGO.png
    Only in ~/projects/Feathercoin/src/qt/res/images: mainbg.grey.1.png
    Only in ~/projects/Feathercoin/src/qt/res/images: mainbg.png
    Only in ~/projects/Feathercoin/src/qt/res/images: mainbg.shade.2.png -
    Only in ~/projects/Feathercoin/src/qt/res/images: mainbg.white.3.png

    Binary files ~/projects/Feathercoin/src/qt/res/images/paper_wallet.png and ~/Feathercoin/src/qt/res/images/paper_wallet.png differ

    Only in ~/projects/Feathercoin/src/qt/res/images: splash.png
    Only in ~/projects/Feathercoin/src/qt/res/images: splash_testnet.png

    Only in ~/projects/Feathercoin/src/qt/res: src


  • Moderators | Tip wrapper

    qttools5-dev dependency : needs adding to the new FTC build instructions in 0.9.6.2 /doc
    for moving to 0.11…


  • Moderators | Tip Wellenreiter

    @wrapper said in [Dev] Feathercoin 0.9.6.2 * Maintenance fix & Issues notes for 0.11.2:

    Tried : Adding -fPIC to CFAGS in makefile

    I’ve modified configure.ac to add -fpic to CXXFLAGS and CFLAGS
    The later is required to compile neoscrypt with --disable static --enable shared:

    if test x$use_hardening != xno; then
      AX_CHECK_COMPILE_FLAG([-Wstack-protector],  HRDENED_CXXFLAGS="$HARDENED_CXXFLAGS -Wstack-protector"])
      AX_CHECK_COMPILE_FLAG([-fstack-protector-all],[HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fstack-protector-all"])
      AX_CHECK_COMPILE_FLAG([-fPIE],[HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fPIE"])
      AX_CHECK_COMPILE_FLAG([-fPIC],[HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fPIC" && CFLAGS="$CFLAGS -fPIC"])
    

    That way the flags are set only, if the code is hardened.


  • Moderators | Tip wrapper

    Lizhis 0.11 build Guide : https://forum.feathercoin.com/topic/8246/guides-how-to-compile-feathercoin-core-0-11-1-on-linux

    Add these dependencies to FTC unix build docs :

    libevent-2.0-5 libevent-dev libevent-extra-2.0-5 libevent-openssl-2.0-5 libevent-pthreads-2.0-5


  • Moderators | Tip AcidD

    on 0.11.2

    when building with this configure command

    I got here:

    
    qt/walletmodel.cpp: In member function ‘WalletModel::SendCoinsReturn WalletModel::createRawTransaction(const QList<SendCoinsRecipient>&, CTransaction&, const CCoinControl*, bool)’:
    qt/walletmodel.cpp:978:134: error: invalid initialization of non-const reference of type ‘int64_t& {aka long int&}’ from an rvalue of type ‘int64_t {aka long int}’
             bool fCreated = wallet->CreateRawTransaction(vecSend, txNew, nFeeRequired, strFailReason, isMultiSig, reservekey, coinControl);
                                                                                                                                          ^
    In file included from qt/walletmodel.cpp:19:0:
    ./wallet/wallet.h:779:10: note:   initializing argument 3 of ‘bool CWallet::CreateRawTransaction(const std::vector<std::pair<CScript, long int> >&, CTransaction&, int64_t&, std::__cxx11::string&, bool, CReserveKey&, const CCoinControl*)’
         bool CreateRawTransaction(const std::vector<std::pair<CScript, int64_t> >& vecSend, CTransaction& txNew,
              ^
    Makefile:5069: recipe for target 'qt/qt_libbitcoinqt_a-walletmodel.o' failed
    
    

  • Moderators | Tip wrapper

    Analysis of Repository file differences

    diff -r ~/litecoin  ~/projects/Feathercoin   | grep ~/litecoin   > diffLite4.txt
    

    Files In litecoin 0.10 but not FTC 0.11

    https://github.com/wrapperband/FTC-Wallet-Layout-Examples/blob/master/Develpment/diffLite4.txt#L786

    Only in ~/litecoin/src/crypto: scrypt.cpp
    Only in ~/litecoin/src/crypto: scrypt.h
    Only in ~/litecoin/src/crypto: scrypt-sse2.cpp

    Only in ~/litecoin/src: db.cpp
    Only in ~/litecoin/src: db.h

    Only in ~/litecoin/src/json: json_spirit_reader.cpp
    Only in ~/litecoin/src/json: json_spirit_value.cpp
    Only in ~/litecoin/src/json: json_spirit_writer.cpp
    Only in ~/litecoin/src/json: LICENSE.txt

    Only in ~/litecoin/src/qt: bitcoinstrings.cpp

    Only in ~/litecoin/src: rpcdump.cpp

    Only in ~/litecoin/src: rpcwallet.cpp

    Only in ~/litecoin/src/test: scrypt_tests.cpp
    Only in ~/litecoin/src/test: wallet_tests.cpp

    Only in ~/litecoin/src/univalue: gen.cpp

    Only in ~/litecoin/src: wallet.cpp
    Only in ~/litecoin/src: walletdb.cpp
    Only in ~/litecoin/src: walletdb.h
    Only in ~/litecoin/src: wallet.h
    Only in ~/litecoin/src: wallet_ismine.cpp
    Only in ~/litecoin/src: wallet_ismine.h


  • Moderators | Tip wrapper

    Analysis of Repository file differences

    diff -r ~/Feathercoin0.11  ~/Feathercoin0.9.6.2   | grep ~/Feathercoin0.9.6.2  > difference2.txt
    

    https://github.com/wrapperband/FTC-Wallet-Layout-Examples/blob/master/Develpment/difference2.txt

    Files In Feathercoin0.9.6.2 but not FTC 0.11 or have been moved

    Only in ~/projects/Feathercoin/share: pixmaps
    Only in ~/projects/Feathercoin/share/qt: extract_strings_qt.py
    Only in ~/projects/Feathercoin/share/qt: img
    Only in ~/projects/Feathercoin/share/qt: make_spinner.py
    Only in ~/projects/Feathercoin/share/qt: protobuf.pri
    Only in ~/projects/Feathercoin/share: ui.rc

    Only in ~/projects/Feathercoin/src: allocators.cpp
    Only in ~/projects/Feathercoin/src: allocators.h
    Only in ~/projects/Feathercoin/src: auxpow.cpp
    Only in ~/projects/Feathercoin/src: auxpow.h
    Only in ~/projects/Feathercoin/src: base40.h
    Only in ~/projects/Feathercoin/src: bitcoin-config.h.in
    Only in ~/projects/Feathercoin/src: core.cpp
    Only in ~/projects/Feathercoin/src: core.h
    Only in ~/projects/Feathercoin/src: crypter.cpp
    Only in ~/projects/Feathercoin/src: crypter.h
    Only in ~/projects/Feathercoin/src: db.cpp
    Only in ~/projects/Feathercoin/src: db.h
    Only in ~/projects/Feathercoin/src: feathercoin-cli.cpp
    Only in ~/projects/Feathercoin/src: feathercoin-cli-res.rc
    Only in ~/projects/Feathercoin/src: feathercoind.cpp
    Only in ~/projects/Feathercoin/src: feathercoind-res.rc
    Only in ~/projects/Feathercoin/src/json: json_spirit_reader.cpp
    Only in ~/projects/Feathercoin/src/json: json_spirit_value.cpp
    Only in ~/projects/Feathercoin/src/json: json_spirit_writer.cpp
    Only in ~/projects/Feathercoin/src/json: LICENSE.txt

    Only in ~/projects/Feathercoin/src/qt: bitcoinstrings.cpp

    Only in ~/projects/Feathercoin/src/qt: coinnectordialog.cpp
    Only in ~/projects/Feathercoin/src/qt: coinnectordialog.h

    Only in ~/projects/Feathercoin/src/qt/forms: aboutdialog.ui

    Only in ~/projects/Feathercoin/src/qt/forms: coinnectordialog.ui

    Only in ~/projects/Feathercoin/src/qt/forms: opennamedialog.ui

    Only in ~/projects/Feathercoin/src/qt/forms: shiftdialog.ui

    Only in ~/projects/Feathercoin/src/qt/locale: bitcoin_de_AT.ts

    Only in ~/projects/Feathercoin/src/qt: Makefile.am
    Only in ~/projects/Feathercoin/src/qt: monitoreddatamapper.cpp
    Only in ~/projects/Feathercoin/src/qt: monitoreddatamapper.h

    Only in ~/projects/Feathercoin/src/qt/res: feathercoin-qt-res.rc
    Only in ~/projects/Feathercoin/src/qt/res: fonts

    Only in ~/projects/Feathercoin/src/qt: shiftdialog.cpp
    Only in ~/projects/Feathercoin/src/qt: shiftdialog.h

    Only in ~/projects/Feathercoin/src: rpcdump.cpp

    Only in ~/projects/Feathercoin/src: rpcwallet.cpp
    Only in ~/projects/Feathercoin/src: script.cpp
    Only in ~/projects/Feathercoin/src: script.h

    Only in ~/projects/Feathercoin/src: stealth.cpp
    Only in ~/projects/Feathercoin/src: stealth.h

    Only in ~/projects/Feathercoin/src: version.cpp

    Only in ~/projects/Feathercoin/src: wallet.cpp
    Only in ~/projects/Feathercoin/src: walletdb.cpp
    Only in ~/projects/Feathercoin/src: walletdb.h
    Only in ~/projects/Feathercoin/src: wallet.h


  • Moderators | Tip Wellenreiter

    @AcidD said in [Dev] Feathercoin 0.9.6.2 * Maintenance fix & Issues notes for 0.11.2:

    on 0.11.2

    when building with this configure command

    I got here:

    
    qt/walletmodel.cpp: In member function ‘WalletModel::SendCoinsReturn WalletModel::createRawTransaction(const QList<SendCoinsRecipient>&, CTransaction&, const CCoinControl*, bool)’:
    qt/walletmodel.cpp:978:134: error: invalid initialization of non-const reference of type ‘int64_t& {aka long int&}’ from an rvalue of type ‘int64_t {aka long int}’
             bool fCreated = wallet->CreateRawTransaction(vecSend, txNew, nFeeRequired, strFailReason, isMultiSig, reservekey, coinControl);
                                                                                                                                          ^
    In file included from qt/walletmodel.cpp:19:0:
    ./wallet/wallet.h:779:10: note:   initializing argument 3 of ‘bool CWallet::CreateRawTransaction(const std::vector<std::pair<CScript, long int> >&, CTransaction&, int64_t&, std::__cxx11::string&, bool, CReserveKey&, const CCoinControl*)’
         bool CreateRawTransaction(const std::vector<std::pair<CScript, int64_t> >& vecSend, CTransaction& txNew,
              ^
    Makefile:5069: recipe for target 'qt/qt_libbitcoinqt_a-walletmodel.o' failed
    
    

    I think you are compiling on a 64bit system. There is a strange definition of int64_t in Linux:

    on a 32 bit linux system:

    typedef int long long int64_t

    on a 64 bit system:

    typedef int long int64_t

    The reason is, that the long in on a 64 bit OS already is 64 bit, while on a 32 bit system it is 32 bit

    If you google int64_t type definition it will lead you to similar problems with other programs.

    By the way, I have the same problem


  • Moderators | Tip wrapper

    Missing from 0.11 :

    bitcoinstrings.cpp missing

    coinnectordialog.cpp
    coinnectordialog.h

    aboutdialog.ui (unpushed update from 0.9.6.1)

    coinnectordialog.ui

    opennamedialog.ui missing?

    shiftdialog.ui

    bitcoin_de_AT.ts

    Makefile.am
    monitoreddatamapper.cpp
    monitoreddatamapper.h

    qt/res: feathercoin-qt-res.rc
    qt/res: fonts

    Various Image Files

    shiftdialog.cpp
    shiftdialog.h

    rpcdump.cpp
    rpcwallet.cpp
    moved

    script.cpp Missing?
    script.h

    stealth.cpp
    stealth.h
    moved

    Various Test Files

    version.cpp

    Only in ~/Feathercoin0.9.6.2/src: wallet.cpp
    Only in ~/Feathercoin0.9.6.2/src: walletdb.cpp
    Only in ~/Feathercoin0.9.6.2/src: walletdb.h
    Only in ~/Feathercoin0.9.6.2/src: wallet.h moved to /src/wallet ?


  • Moderators | Tip Wellenreiter

    the file structure has changed, so some of the listed files may not be needed anymore

    It needs deeper checking


  • Moderators | Tip wrapper

    Merge 0.9.6.2 with 0.11
    Just looking at pulling in all the 0.9.6.2 fixes, see if that corrects the build problem. I’d rather work on re-implementing a few 0.11 specific files than find a possible .gitignore missing file or setting only @Lizhi has on his PC…

    I have created a working document, to assist or add to the document, fork the repository https://github.com/wrapperband/FTC-Wallet-Layout-Examples/blob/master/Develpment/0.11-0.9merge Conflicts.txt and update the document. Push any changes.

    To work on the merge, create a branch of 0.11, clone it, then replace the names with your test branch, create the pull, then use the command line to merge. Note : normally merges would be the other way round, in this case 0.9.6.2 is building and 0.11 is not. …

    https://github.com/wrapperband/Feathercoin/pull/1

    git fetch origin
    git checkout -b 0.9.6.2 origin/0.9.6.2
    git merge 0.11.2-wrapper

    These files have conflicts, 0.11 should be used.
    src/alert.cpp
    src/alert.h
    src/base40.h
    src/base58.cpp
    src/chainparams.cpp
    src/chainparams.h

    These need checking but shouldn’t be stoppers.
    share/pixmaps/bitcoin.ico
    share/pixmaps/nsis-header.bmp
    share/pixmaps/nsis-wizard.bmp


  • Moderators | Tip wrapper

    configure.ac

    0.9.6.2 specific merge conflict

    define(_CLIENT_VERSION_MINOR, 9)
    define(_CLIENT_VERSION_REVISION, 6)
    define(_CLIENT_VERSION_BUILD, 2)
    define(_CLIENT_VERSION_IS_RELEASE, false)
    define(_COPYRIGHT_YEAR, 2017)
    AC_INIT([Feathercoin Core],[_CLIENT_VERSION_MAJOR._CLIENT_VERSION_MINOR._CLIENT_VERSION_REVISION],[[email protected]],[feathercoin])
    AC_CONFIG_AUX_DIR([src/build-aux])
    AC_CONFIG_MACRO_DIR([src/m4])

    Merged version is 0.11 - Structure of build is changed. Updated the support issues referance to github.

    define(_CLIENT_VERSION_MINOR, 11)
    define(_CLIENT_VERSION_REVISION, 2)
    define(_CLIENT_VERSION_BUILD, 6)
    define(_CLIENT_VERSION_IS_RELEASE, false)
    define(_COPYRIGHT_YEAR, 2017)
    define(_USE_ZXING,1)

    AC_INIT([Feathercoin Core],[_CLIENT_VERSION_MAJOR._CLIENT_VERSION_MINOR._CLIENT_VERSION_REVISION],[https://github.com/Feathercoin/Feathercoin/issues],[feathercoin])
    AC_CONFIG_SRCDIR([src/main.cpp])
    AC_CONFIG_HEADERS([src/config/bitcoin-config.h])
    AC_CONFIG_AUX_DIR([build-aux])
    AC_CONFIG_MACRO_DIR([build-aux/m4])


  • Moderators | Tip wrapper

    configure.ac

    HEAD
    ]])],[boost_sleep=yes; BOOST_LIBS="$BOOST_LIBS $BOOST_CHRONO_LIB";
    AC_DEFINE(HAVE_WORKING_BOOST_SLEEP_FOR, 1, [Define this symbol if boost sleep_for works])],[boost_sleep=no])


    ]])],
    [boost_sleep=yes;
    AC_DEFINE(HAVE_WORKING_BOOST_SLEEP_FOR, 1, [Define this symbol if boost sleep_for works])],
    [boost_sleep=no])

    ---- origin/0.11.2-wrapper

    LIBS="$TEMP_LIBS"
    CPPFLAGS="$TEMP_CPPFLAGS"

    if test x$boost_sleep != xyes; then
    TEMP_LIBS="$LIBS"
    LIBS="$BOOST_LIBS $LIBS"
    TEMP_CPPFLAGS="$CPPFLAGS"
    CPPFLAGS="$CPPFLAGS $BOOST_CPPFLAGS"
    AC_LINK_IFELSE([AC_LANG_PROGRAM([[

    #include <boost/version.hpp>
    #include <boost/thread.hpp>
    #include <boost/date_time/posix_time/posix_time_types.hpp>
    HEAD

    ]], [[

    =======

    ]],[[

    ------ origin/0.11.2-wrapper

    #if BOOST_VERSION <= 105600
    boost::this_thread::sleep(boost::posix_time::milliseconds(0));
    #else
    choke me
    #endif

    ----- HEAD

    ]])],[boost_sleep=yes; AC_DEFINE(HAVE_WORKING_BOOST_SLEEP, 1, [Define this symbol if boost sleep works])],[boost_sleep=no])


    ]])],
    [boost_sleep=yes; AC_DEFINE(HAVE_WORKING_BOOST_SLEEP, 1, [Define this symbol if boost sleep works])],
    [boost_sleep=no])

    ------- origin/0.11.2-wrapper