Supported Feathercoin client versions: Current production Version: 0.16.1.

Old Production Version: 0.16

Info: If you have problems to post, create one post in the ‘newbies’ category and try again. If you have further problems, find support under Guides

any GPU miner to solo mine feathercoin/neoscrypt for linux?



  • I’ve tried NSGminer GPU but it’s somehow not working well even block solved but not crediting to account, seems some glitch with nsgminer.

    So any recommendation for solo miner that has coinbase GBT support for neoscrypt will be appropriated?


  • Moderators

    Can you give us more info on your setup? You say you found blocks but they were not credited?



  • Well I’ve tried nsgminer with guncoin, phoenixcoin and Feathercoin. NSGminer version compiled for CPU works fine, however GPU which is by default, Pool, Information it tells block is solved, however check account there is no clue of any transaction.

    these are the paramenters i’m using both with cpu and gpu, cpu nsgminer works fine and solved block is credited (guncoin).

    ./nsgminer -o http://127.0.0.1:9337 -u rpcusername -p rpcpassword --coinbase-addr=xxxxxxxxxxxxfeathercoin adddressxxxxxxxxxxxxx -D --verbose


  • Moderators

    maybe something went wrong during your compile…

    Did you try the NGMiner pre-compiled binaries ?



  • @acidd I tried and compiled nsgminer on 5 different machines and result is the same, I’m using ubuntu 16.04.3 lts version. Blocks are found but actually they are never materialized. I’ve reported to developer at Github: ghostlander (John Doering) he’s still looking into it I guess.

    Even I’ve discussed same issue with Guncoin’s Peter Bushnell and he told me he ask sent a message to John Doering. Peter Bushnell said "The miner may not like Version Bit blocks. I’ll check with the developer.", so he did report to nsgminer developer.

    Perhaps you can test yourself but use GPU version, it might help to find out what’s going wrong.