Supported Feathercoin client versions: Current production Version: 0.16.0.

Old Production Version: 0.13.2

Info: If you have problems to post, create one post in the ‘newbies’ category and try again. If you have further problems, find support under Guides or use the shoutbox

Corrupted block database detected.


  • Regular Member

    Upgraded to .13 wallet. Closed old wallet, installed .13. reopened, now i get the “Corrupted block database detected.” And then it says, " Do you want to rebuild the block database now?" I’m rebuilding it now, if that doesn’t work, any thoughts on what I need to do? Thank you in advance!


  • Moderators

    if the blockchain database is corrupted.

    You should

    1 - back up your private keys
    2 - backup your wallet.dat
    3 - verify both backups like a good boy
    4 - delete the blocks and chainstate folder in your datadir

    5 - start Feathercoin-qt again and let it resync.


  • Moderators

    That happens when upgrading to 0.13

    The rebuild of the database will work and your coins are safe.
    If not, follow the procedure @AcidD described.


  • Regular Member

    @acidd acid man… what would the ftc community do without you. beautiful. just beautiful. THANKS BUDDY! Now come and see me to hook you up with some ink!


  • Moderators

    @addamnorth said in Corrupted block database detected.:

    @acidd acid man… what would the ftc community do without you. beautiful. just beautiful. THANKS BUDDY! Now come and see me to hook you up with some ink!

    Marked as solved!

    @addamnorth - it’s always a team effort. I was taught by some of the more senior community members who have been around for much longer than myself.

    I have them to thank 🙂


 

Looks like your connection to Feathercoin Forum was lost, please wait while we try to reconnect.