Feathercoin daemon and wallet production version 0.19.1
Old daemon and wallet version 0.18.3

Can't start mining...?

  • Moderators | Tip Wellenreiter

    @clickinorka said in Can't start mining...?:

    @wellenreiter Thank you for getting back to me Wellenreiter.

    990x Hexcore Processor
    24GB DDR3
    GTX980 Vid

    I dl’d the NSG and SG Miner but couldn’t figure out how to even launch it. All the icons are blank.

    NSG and SG Miner are command line tools. To start either of them you need to open a command line window:

    • click the menu icon at the lower left of the screen
    • in the line ‘run’ enter ‘cmd’, this will open the command lind window

    Then locate where the mining program you want to start is located in your directory. the file name is ‘sgminer.exe’ and - I think- nsgminer.exe

    • use the command line window and change into that directory
    • type ‘sgminer -help’ to get all options.
      you need to set the algorithm to neoscrypt, host= localhost, user = rpcuser from feathercoin config file password = rpcpassword from feathercoin config file.

    The feathercoin config file is located in %appdata%\feathercoin\

  • | Tip ClickinOrka

    @wellenreiter Thanks Well. I’ll look into it in the morning. I just checked both folders for NSGMiner and SGMiner and none of each contained a .exe file. One of the videos on youtube recommended something else, CCMiner perhaps. I can’t recall. Kapersky caught it with a bunch of trojans & virus packed inside. There’s no way this should be this bloody complicated.

  • | Tip ChekaZ

    Hey there,

    Nvidia I would always recommend CCminer, here is the best version:

    Now you need to setup a .conf File in your %appdata%/Feathercoin Folder, which needs to contain following lines


    Save that as “all files” and name it feathercoin.conf

    Restart your wallet after you did that.
    Now we need to configure your miner, for Solomining you have to point it to your localclient:

    Create a .bat next to your miner.exe

    Put this inside:

    ccminer.exe -a neoscrypt -o -u username -p password

    Doubleclick the .bat and it should fire up the mining and mine towards your local client

  • | Tip ChekaZ

    I havent updated the GUI-Miner yet, so please use it as described above.

    Its on my todo list but Iam kinda busy with other stuff right now.

  • | Tip jimmy24651

    When I first started trying to mine, I beat my head up against a wall (figuratively) for quite a few days before I finally found success. Stick with it, and you’ll eventually get it working.

    As far as your comment that there’s no way this should be this complicated, that’s exactly how I felt when I got started. The longer I messed around with it, the less I felt this way. Once you get it working, you’ll feel a great sense of accomplishment, and every thing you try afterwards will be that much easier. FTC was the first coin I ever mined, so I learned the most from it. Since then, I have mined pretty much every coin you can think of, at least a little. Trust me when I tell you that all of the coins I mine since then have been much easier…not because it is hard to mine FTC, but because I learned so much with FTC, I was able to apply that knowledge across the board.

    The first thing you have to bear in mind is that most miner programs were developed with a specific type of GPU in mind. Since you said you’re using a GTX, I would start with CCMiner, and ChekaZ recommended. CCMiner is the most efficient miner I found to work.

    • Join a pool. My favorite pool is the “official” pool which is ran by the developers on this forum. This pool charges no fee, so if you end up sticking with mining, I would highly recommend donating to the pool as a thank you to these guys!


    -Download whatever version of CCMiner you choose (typically, the newer ones are faster)

    My favorite miner is here: https://github.com/ghostlander/cudaminer-neoscrypt create a text document in the same folder with the miner.

    • Put this line in the body of the text file:

    “cudaminer-x64.exe” -o “stratum+tcp://pool.feathercoin.com:6056” -u “worker” -p “password”

    All of the fields which I put quotation marks around are going to be specific to your mining program, your pool, and your worker name on the pool. You need to remove all quotation marks from your actual file. After entering all of this info, you want to save the file with .bat at the end, rather than .txt

    This is what my .bat file looks like -
    cudaminer-x64.exe -o stratum+tcp://pool.feathercoin.com:6056 -u jimmy24651.4 -p x

    jimmy24651 is my login on the pool, and this particular worker is named 4.

    Run this batch file, and you should be good to go.

    I try to keep up on here as much as possible, so if this doesnt work, let me know and I’ll try to respond as soon as possible.

    I hope this helps!

  • | Tip jimmy24651

    @chekaz I believe that the newer versions of the wallet make solo mining with the strategy you offered impossible. I solo mined for quite a while just as you stated, but once the wallet got to .13 (I believe), it was no longer possible. From the questions I asked on here, I think it had something to do with getwork vs getblock or something like that.

  • | Tip ClickinOrka

    Well, we’ve made some progress. I made an account on the feathercoin mining pool, added a worker and all that. Upon activation of the CCMiner.bat, Kapersky Antivirus starts throwing up redflags. Deactivating and trying again, the command window does stay up, and this is what I’m currently seeing. In addition, is the CC able to make to make use of my CPU? Was hoping to use both the hex-core and 980 on my primary system if possible. Just tried the same thing with GUI and Kapersky found it a threat and deleted it instantly. lolz Getting the feeling that an antivirus may be an issue…


  • | Tip jimmy24651


    Well, you’re definitely not mining.

    You are connected, because the miner is showing new blocks as they come in. I can’t be 100% certain of this, but it seems as though the antivirus is what is causing your problem. Some of these guys who know more about the technical side may be able to look at your log file and let you know for sure, but for now (since it may take them a little while to see this), I would definitely try just totally disabling your antivirus to see if that corrects the problem. If it does, at least you know what you’re looking for. Past that, I don’t know enough about your antivirus to really give you any advice on how to get around it.

  • | Tip ClickinOrka

    Disabling and shutting down Kapersky made no difference. The CMD window shows the same error. “Stratum Authentication Failed”. I built this system years ago X58 UD3R. The video card may be up to date, but now I’m wondering if the board itself is holding me back.

    Feathercoin wallet
    Signed up to the feathercoin mining pool. stratum+tcp://pool.feathercoin.com:6056

    Am I missing another program?

  • Moderators | Tip Wellenreiter

    @clickinorka No, you don’t need another program.
    I’m not sure, but do you see your miner as active on the pool? It should be possibble to determine the status of your workers from your account page on the pool.

    The stratum error means, that the pool doesn’t send any work for your miner, may be because it doesn’t accept the credentials your miner provides at logon.

    Also in very rare situations a firewall can block the stratum communication.

  • | Tip ClickinOrka

    WOW. Bloody hell. lol Im so sorry for wasting your time. I pulled a huge stupid. I assigned my worker name GTX980 and neglected putting my username and the period infront of it. Seems to be working now at 800kH/s. All 6 CPUS of the 990x are at 0%, so that sucks. But hey, made some damn good progress thanks to all your guidance. Would like to use em too if possible. This has been an interesting learning experience. Looking forward to seeing how this pans out before purchasing a B250 board or two.

  • Moderators | Tip Wellenreiter

    In order to get your CPUs mining you need to install another program named cpuminer.

    ccminer doesn’t support CPU mining in paralle to GPU mining.

  • | Tip ClickinOrka

    @chekaz Hey Chekaz, I don’t think you need to update the GUI Miner. I just tried all the login info with it, along with selecting my CPUS I wanted to contribute (all 6 in the test) and unless I’m mistaken, it seems to be working. Confirmation and/or thoughts?

    0_1524534362672_GUIMiner Online And Working.jpg

    UPDATE: Um… nevermind? The Dashboard on my FC page shows no activity. So if the thing is working… ??? In addition, it works without my username and password. Host and port and click the mine button, and it seems to do just that. The best part, Kapersky doesn’t go tripping balls when this thing is activated.

  • | Tip Tobi97l

    That it works without a username or a password is normal. You don’t need that for mining. You only need it if you want the coins to be credited to your account. And to be able to login to your account to withdraw coins.

    The reason why you don’t get shares on the pool is because the gui miner is completely outdated. I think it still uses the scyrpt algo instead of neoscrypt. So all your shares are getting rejected by the pool. You can see that your hashrate is at over 700Mhash/s. A gtx 980 can probably do 800-900Khash/s with neoscrypt.

    As already mentioned above you should use ccminer. I can provide you with an example .bat file late if you need help with that.

    Also the reason why your anti virus is going nuts when you install a miner is because there is a lot of malware that contains miners that steal you cpu and gpu power. That’s why they always flag them as malicoius. So you can ignore these warnings.

  • | Tip ClickinOrka

    @tobi97l Thanks Tobi that makes alot of sense. I am getting a solid 800Kh/s. I’ve been using CCMiner since I started, that’s running my GPU in the command window posted two replies above.

  • | Tip ClickinOrka

    @wellenreiter Hey Well, thanks for recommending CPUMiner. I looked though the “README” and went to the forums for Q&A. https://bitcointalk.org/index.php?topic=55038.0 there in it states a “minerd.exe” to which the archive doesn’t have that file. The post was made in 2011, so its not a shock that the file may not longer exist in a new build. It does have a “minerd.1” file. In short, I have no bloody clue how to make this work either.

    0_1524624085690_CPUMiner Archive.jpg

  • Moderators | Tip Wellenreiter

    @clickinorka said in Can't start mining...?:

    It does have a “minerd.1” file. In short, I have no bloody clue how to make this work either.

    You got the source code, which needs to be compiled to create minerd.exe

    It may be easier to get the binary from here: https://github.com/ghostlander/cpuminer-neoscrypt/releases

    If you search for ‘minerd’ here in the forum you’ll find several examples how to start minerd from the command line.

  • | Tip ClickinOrka

    @wellenreiter Thanks Well. I created a new worker profile and basically copied the info from the .bat file you guys had me create to start CCMiner. Changed the info to the new worker.

    minerd.exe -a neoscrypt -o stratum+tcp://pool.feathercoin.com:6056 -u ClickinOrka.xxxxxx -p xxxxxxxxxxxx

    Took a short while but they worker did appear on my “dashboard” for a brief moment. However with 6 cores, it only appeared to provide 36kh/s across all 12 threads. That can’t be right???
    0_1524643426268_CPU Hash Test.jpg
    I’d like to think I can muddle though, read previous Q&A’s and learn without bugging all yall, but I’d also like to get it right and not half ass it. Please let me know if I made a mistake. I’d have thought that a hexcore processor would do more then 1 video card.

  • Moderators | Tip Wellenreiter

    Well, I can’t tell much, but your CPU’s get about the same hash rate I got when trying CPU mining.

    I move the thread to the mining section, so other the mining people may respond also.

    You should be able to post in the mining section, too now.

  • | Tip ClickinOrka

    @wellenreiter Thanks Well. It all goes well now aside from the CPU part. Been a good 3-4 days and I can’t make it more than a mere few, like the pic posted above. Is there a special address I should be connecting to for the CPU side? The CPU worker doesn’t appear most of the time, and when it does, its up for a moment and is gone again. Seems to be 99% ignored. So it does do its thing, just doesn’t seem that credit is being given for the effort. CPU miner is 2.4.3.

    0_1524975342342_GPU CPU.jpg
    0_1524975360004_GPU CPU 2.jpg

Log in to reply