Feathercoin daemon and wallet production version 0.19.1
Old daemon and wallet version 0.18.3

FTC Wallet

  • Regular Member | Tip Time2Shine

    Is anyone having trouble syncing their wallet past 23 hours? I have a pending transaction and I have not received my coins because my wallet is still syncing… Need help quick!

  • Regular Member | Tip tmuir12

    Not in Australia.

    What version of wallet are you using?

    Have you updated to atleast wallet ?

    If you have not updated to this version or higher you may have problems syncing.

    I just turned on a full Node in Australia last night to help with syncing and hopefully in the next day or two will release the scripts so others with a spare Raspberry Pi can do the same.

  • Moderators | Tip Wellenreiter

    If your wallet does a full sync, for example, because you did a clean install, then some hangs have been reported.

    The normal workaround is to close the wallet and start it again.

  • Regular Member | Tip Time2Shine

    I’ve closed the wallet numerous times… Any other suggestions? Is there any alternate wallets I can use to get a good blockchain that will have mine in it?

    If this helps, it worked fine up until the fork when I have to update…

  • Regular Member | Tip tmuir12

    Are you connecting to other nodes?

    The little indicator on the bottom right of your wallet does it have a green tick?

    If it doesn’t for some reason you may be having trouble finding nodes.

    Do you now how to create a conf file?

    If you do set one up and add this line to it


    That is the current IP address for a full node I’m running, although a check this morning and I already had 97 peers and the limit is 100, so if I’ve reached 100 it may take a little while for you to connect as one drops off.

    As long as you have a backup of your wallet.dat nothing will be lost

    Have you checked the explorer to see if the transaction went through?


    Another way to check the balance is with the api on the feathercoin website

    Use this link and just replace the address in it with the one of your account you want to check


    If this still deosn’t work let us know

  • Regular Member | Tip Time2Shine

    Yes, I have a green tick with 16 active connections. Also, using the websites you have provided, it doesn’t show the transaction going through. Everytime I check the status on the transaction, the confirmations keep going up. Maybe it is taking awhile to confirm the coins? Idk, please explain if you have an idea.

    How do you setup the addnode?

  • Regular Member | Tip tmuir12

    If you have 16 active connections you do not need to set up a conf file, you only really need that if you are having problems connecting.

    Can you confirm you are running wallet 8.7.0 or 8.7.1

    If you are running a wallet older than that you will have issues.

    Basically have you updated your wallet in the last couple of weeks, if you haven’t that is most likely your problem?

  • Regular Member | Tip Time2Shine

    in the About Feathercoin section is says version v0.8.7.0-beta-qr

  • Regular Member | Tip tmuir12

    Ok your wallet is new enough…

    Looks like for some reason you have a glitch though.

    Does it tell you how many days or hours behind you are with the syncing?

    Is this getting further behind?

    Basically you are not downloading any new blocks?


    Then close the wallet

    We will try to reindex the blockchain

    I’m assuming you are using windows

    Right click on the icon you use to launch feathercoin

    Select properties

    On the line that has the directory and filename it launches go to the very end and enter ‘-rescan’ without the quotes

    Now start feathercoin and it will rescan the whole blockchain and hopefully fix the error.

    Make sure after doing this you remove ‘-rescan’ from the properties or it will do this every time you launch which you don’t want as it will take some time to do a rescan.

    If this still doesn’t work we need to try something more drastic

    Copy out the directory ‘blocks’ and ‘chainstate’ and store them else where on your pc and restart the wallet.

    It will then download the whole blockchain again but being its over a gig it will take a while.


    As long as you have a backup of your wallet you will not loose anything, forget to backup your wallet and you could regret that.

    If you don’t know where to find the blocks and chainstate directory click on the start menu and type in %appdata% in the search box and enter****

    Scroll down in the window that opens until you see feathercoin****and they will be inside this directory.

    If neither of those solution work, we will need to get someone more knowledgeable than me to help

  • Regular Member | Tip Time2Shine

    Ok. I am downloading the whole blockchain right now. I have already went to %appdata% and saved that entire folder along with the wallet.dat file else where on my computer. I hope I’m doing this right…

    Also, it keeps stopping at 23hrs behind and I’ll check every so often and the blocks go up by very few at a time but still says 23hrs behind.

    After this download finishes, if it doesn’t fix it, I will try the -rescan next…

    its at 300106 out of 443366 (estimated) at the moment.

  • Regular Member | Tip tmuir12

    That will be file I also suggest youuse the backup wallet command inside the wallet to save the wallet.dat file to a USB stick so if you have a hard drive failure ever you still have a copy of the wallet.dat that you can then re-import.

    Odd how it always stop 23 hours behind.

    Just a silly thought is the clock on your PC showing the correct time?

    I have heard of people having issues if the CMOS battery goes flat on their PCs before

  • Regular Member | Tip Time2Shine

    I think so. Should the time be adjusted to something other than eastern standard? Im in the eastern timzone.

    How does the CMOS batt go flat?

  • Regular Member | Tip tmuir12

    No just set it to your local time that is ok.

    The batteries can go flat if your PC is a number of years old, like any rechargeable battery they just eventually wear out, but usually most people replace their PC before the battery wears out.

    I’m talking about if your pc thinks its last month, or if its set to Eastern time but the clock is not showing the correct time for where you have set it, then that could be an issue.

    You also usually get a warning message on bootup if you have cmos battery problems.

  • Regular Member | Tip Time2Shine

    Ok it stopped at 23 hours again… arrgghh

    I need to fix this asap

    When it reaches 23 hours the to arrows that spin in a circle that shows progress stops and says “Catching Up”…

  • Regular Member | Tip tmuir12

    I’ve asked those more knowledgeable than me to help, but can you see what block number it is stuck at?

    You can get this by going to the console and typing


  • Regular Member | Tip Time2Shine

    Where exactly is the console and what is it?

    And also it says 444762, but it never actually freezes.

    When you hover your mouse over the green sync bar it says…

    "Catching up…

    Processed 444765 blocks of transaction history.

    Last received block was generated 23 hours ago.

    Transactions after this will not yet be visible"

    Even though it is stuck at 23 hours, the processed block count keeps rising. Now it is at 444767.

  • Regular Member | Tip tmuir12

    Current block is 444,865 and as its about 2 hours since your post that would be about right.

    Something odd is going on here because if you are up to block 444765 you are up to date.

    Sounds to me like you have some odd time stamp issue going on.

    To get to the console, click on the help menu optin in the wallet, then select ‘Debug window’ then click on the console tab and you are there

    If you type help into the box at the bottom it will give you a list of commands you can use

    If you type getinfo in there it will list the latest block you have synced to.

    Then go to a FTC mining website and see what they list as the latest block.

    If they are the same or only 1 or 2 different you are up to date, as it can sometimes take a minute or 2 for the latest block to propagate to all wallets.

    If you look here http://www.wemineftc.com/stats

    It will give the stats the blockchain is up to.

    If your wallet and the website above agree its the same block it would make me think its still some odd issue with the time on your PC.

    Have you set the clock on windows to automatically sync itself to the correct time?

  • Regular Member | Tip Time2Shine

    Well, when I check the debug window the blocks are matching up, but for some reason won’t go past 23 hours.

    Figured out the issue. I had to go in to my computers time settings and sync time with an online source. Wow, what a pain the arse.

    Thanks so much for your help tmuir12. As soon as this next transaction goes through, I’ll hook you up!

  • Regular Member | Tip tmuir12

    I had a feeling it was something to do with the time on your pc.

    An extra check the wallet does is check the timestamps on the blocks against the time on your PC and if the timestamp on the block is out of whack with your PC it won’t fully sync up.

    Its a pain but its essentially part of the security protocol of the block chain to stop people faking blocks.

    Glad you got it sorted in the end.

  • | Tip lizhi

    my 0.9.3 core wallet ,the synchronization of all the blockchain of spending 12 hours.

Log in to reply