Feathercoin daemon and wallet production version 0.19.1
Old daemon and wallet version 0.18.3

Wallet slow to sync


  • Regular Member | Tip engetsu

    I’m stuck 34 weeks for the past 3 days , i added many nodes but it wont move . Stuck on 1673771 .

    how can i fix this

    {
    “version” : 90602,
    “protocolversion” : 70006,
    “walletversion” : 60000,
    “balance” : 0.00000000,
    “blocks” : 1673771,
    “timeoffset” : 0,
    “connections” : 10,
    “proxy” : “”,
    “difficulty” : 11.80062474,
    “testnet” : false,
    “regtest” : false,
    “keypoololdest” : 1510897040,
    “keypoolsize” : 101,
    “paytxfee” : 0.00000000,
    “relayfee” : 0.01000000,
    “errors” : “”
    }

    19:30:11
    [
    {
    “addr” : “46.127.12.33:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038593,
    “lastrecv” : 1513038578,
    “bytessent” : 5842,
    “bytesrecv” : 98252,
    “conntime” : 1513038451,
    “pingtime” : 0.00000000,
    “version” : 70005,
    “subver” : “/Feathercoin:0.9.6.1/”,
    “inbound” : false,
    “startingheight” : 2001307,
    “banscore” : 0,
    “syncnode” : true
    },
    {
    “addr” : “50.43.47.187:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038570,
    “lastrecv” : 1513038522,
    “bytessent” : 480,
    “bytesrecv” : 30428,
    “conntime” : 1513038452,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 342315,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “142.118.58.13:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038581,
    “lastrecv” : 1513038581,
    “bytessent” : 4771,
    “bytesrecv” : 49392,
    “conntime” : 1513038452,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 2001307,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “159.100.247.136:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038608,
    “lastrecv” : 1513038577,
    “bytessent” : 4997,
    “bytesrecv” : 53219,
    “conntime” : 1513038453,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 2001307,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “104.129.57.113:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038577,
    “lastrecv” : 1513038577,
    “bytessent” : 3625,
    “bytesrecv” : 94025,
    “conntime” : 1513038454,
    “pingtime” : 0.00000000,
    “version” : 70005,
    “subver” : “/Feathercoin:0.9.6.1/”,
    “inbound” : false,
    “startingheight” : 2001307,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “193.108.117.202:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038577,
    “lastrecv” : 1513038577,
    “bytessent” : 3796,
    “bytesrecv” : 49478,
    “conntime” : 1513038454,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 2001307,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “74.80.53.118:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038608,
    “lastrecv” : 1513038611,
    “bytessent” : 4948,
    “bytesrecv” : 50026,
    “conntime” : 1513038460,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 2001307,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “23.92.136.71:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038577,
    “lastrecv” : 1513038606,
    “bytessent” : 4826,
    “bytesrecv” : 49840,
    “conntime” : 1513038461,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 2001307,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “5.81.243.54:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038513,
    “lastrecv” : 1513038513,
    “bytessent” : 370,
    “bytesrecv” : 346,
    “conntime” : 1513038461,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 767163,
    “banscore” : 0,
    “syncnode” : false
    },
    {
    “addr” : “71.229.233.189:9336”,
    “services” : “00000001”,
    “lastsend” : 1513038469,
    “lastrecv” : 1513038470,
    “bytessent” : 370,
    “bytesrecv” : 346,
    “conntime” : 1513038468,
    “pingtime” : 0.00000000,
    “version” : 70006,
    “subver” : “/Feathercoin:0.9.6.2/”,
    “inbound” : false,
    “startingheight” : 1157131,
    “banscore” : 0,
    “syncnode” : false
    }


  • Moderators | Tip Wellenreiter

    @engetsu

    Your wallet currently -or at the time you got the list of peers- syncronizes with this node : “46.127.12.33:9336”

    Try to close the wallet and start again.

    This has been reported to get hanging synchronizations to move again.

    After starting the wallet again, you can check that the wallet uses a different node to download data.

    This is reflected in the ‘syncnode’ flag of the peers.


  • Regular Member | Tip engetsu

    @wellenreiter
    Thanks for the info , i closed and opened it many times and it still hangs there , on information tab i number of connections see 10 ( in = 0 / out = 10 )

    When i restart , i always get a different address showing True but it stays hanging .

    What do i do now ?


  • Regular Member | Tip Phlosen

    Hi @engetsu,

    I had the same issue on Ubuntu and Win. I went here http://cryptochainer.com/dir/?page_id=881
    and downloaded the .zip
    Close your wallet, copy the files into the Data Folder (maybe backup the old ones, just in case…). Start your Wallet and you should only be come days behind. Wallet quickly syncs and you are good…

    Hope this helps!!


  • Regular Member | Tip engetsu

    @phlosen

    thanks for the link but the idea of me getting the core is to havea safe wallet . Downloading something from a site for my wallet does not really seem secure .

    Also why can’t this core wallet work like it’s suppose to ? why so many bugs and so much time to sync.

    i deleted everything and re installed the program and it’s been 3 days now on continuous connection on a 30 MB internet speed .

    I’m at 1 year and 17 weeks behind , is it suppose to take this much time ?


  • Regular Member | Tip gonnaforget

    @engetsu I thought the thing that took time is not the download, but the processing.


  • Moderators | Tip wrapper

    @engetsu

    My tests showed the sync with 0.9.6.2 took consistently ~25 hours, using the blockdata.dat - a fast PC with > 16 GB RAM.

    Can I ask what PC you are using? memory / clock speed?


  • Regular Member | Tip engetsu

    @wrapper

    im doing it from my laptop , i3 with 8gig of ram , ssd .

    So woke up today and i think it finished syncing , fire up feathercoin app and now i get an error message saying "connect a new block to chainactive , failed to read block " .and then shutsdown

    Tha hell is wrong with this wallet why is it only problems , what are the devs going to do if it ever becomes mainstream and everyone wants to buy themselves some FTC .

    i uninstalled and re installed but i still get the message . Do i have to delete everything again and download restart the whole process again ?


  • Moderators | Tip wrapper

    @engetsu - I deleted the swearing as this is a highjack of someone else welcome thread.

    You can try : Start the client with the -reindex command-line option.

    Otherwise yes, the bitcoin programmers have included error checking in the code that you sometimes have to do something about , sorry.

    Contribute to FTC development and bug fixing : 6p8u3wtct7uxRGmvWr2xvPxqRzbpbcd82A


  • Moderators | Tip AcidD

    @engetsu - I appreciate your frustration. We are working to sort out all of these sync issues in our next release.

    if you’re on windows…

    • make a shortcut to feathercoin-qt on your desktop
    • right click and click properties
    • add the following to the end of the Target path

    "C:\Program Files\Feathercoin\feathercoin-qt.exe" -maxorphantx=5000 -maxblockorphans=12000 -dbcache=4096 -rescan

    let us know how you get on.


  • Regular Member | Tip Anema

    For your information guys this command line doesnt work

    “C:\Program Files\Feathercoin\feathercoin-qt.exe” -maxorphantx=5000 -maxblockorphans=12000 -dbcache=4096 -rescan


  • Moderators | Tip AcidD

    Could you please go into more detail?

    “Doesn’t work” makes it hard for us to provide support.


  • newbies | Tip Michu

    I have been downloading the Feathercoin blockchain for 2 weeks, I have 1 year and 27 weeks left. I have a very good connection. It’s sloooow.


  • Regular Member | Tip Anema

    @acidd

    Nothing has changed . It stuck like this … It has been 1 week now 🙂 It is working 24/7 also i can share the debuglog file if you want

    2017-12-19 22:17:13 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=b3e153f5f315adcd446bab4c05ccf014da93f3cbe056bb28033350973ff79d15
    2017-12-19 22:17:13 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=3dd4e05b659112e11ad433df3e0aa6abdb7911b4a5491849e2906e0e6bb6f0e7
    2017-12-19 22:17:13 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=7eefb7831194684ccb2bedd3fe420e15f1ce59048a48c819fcad2efe37eff866
    2017-12-19 22:17:14 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=838fed5258c63030274996d286ec54ec9e1b52c2aa1aba669dd05dec99e18308
    2017-12-19 22:17:14 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=dd500d98216417d37f8f4d2b2b5bfe7b351b5bfc345c5802cc60335813078b8c


  • Regular Member | Tip Anema

    @anema said in Wallet slow to sync:

    @acidd

    Nothing has changed . It stuck like this … It has been 1 week now 🙂 It is working 24/7 also i can share the debuglog file if you want

    2017-12-19 22:17:13 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=b3e153f5f315adcd446bab4c05ccf014da93f3cbe056bb28033350973ff79d15
    2017-12-19 22:17:13 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=3dd4e05b659112e11ad433df3e0aa6abdb7911b4a5491849e2906e0e6bb6f0e7
    2017-12-19 22:17:13 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=7eefb7831194684ccb2bedd3fe420e15f1ce59048a48c819fcad2efe37eff866
    2017-12-19 22:17:14 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=838fed5258c63030274996d286ec54ec9e1b52c2aa1aba669dd05dec99e18308
    2017-12-19 22:17:14 ProcessBlock() ProcessBlock: ORPHAN BLOCK 7501, prev=dd500d98216417d37f8f4d2b2b5bfe7b351b5bfc345c5802cc60335813078b8c

    and to be honest I check those hash numbers by one by not all of them I dont know why it says Orphan


  • Moderators | Tip AcidD

    Hi @Anema

    this is the expected behaviour. You just need to leave your machine on and set it to not go onto standby or sleep mode.

    Leaving it on for 1 week 24/7 - and you can guarantee it’s been online that whole time… then something else might be wrong with your setup.

    The orphan blocks are blocks that have to be processed - in the past Feathercoin had attacks on it’s blockchain and this caused orphan chains to happen.


  • Regular Member | Tip Anema

    I think from now on the best thing to do just leave the computer open . About my setting I have no idea I just downloaded the setup and then Install it . I dont think I have a problem with my firewall or anything else. Ty for the info btw


  • | Tip Moonman

    I did a try from fresh, for the sake of benchmarking and potential useful info.
    So far, 36 weeks behind @2days 19hours, will report in upon completion.


  • Moderators | Tip wrapper

    @moonman said in Wallet slow to sync:

    I did a try from fresh, for the sake of benchmarking and potential useful info.
    So far, 36 weeks behind @2days 19hours, will report in upon completion.

    Whats the spec / memory CPU speed of the PC?


  • | Tip Moonman

    @wrapper
    will do a complete spec and times post when its complete, but its an hp tm2 touch laptop with core2duo cpu ~1.5sth ghz, 8gb ram (ddr3 800 if i remember well)


Log in to reply