Feathercoin daemon and wallet production version 0.18.1
Old daemon and wallet version 0.17.0.1

FeatherCoin 0.8.5 Client Portable - Linux


  • | Tip PaperNick

    Hello guys!

    I’ve had some trouble installing and running Feathercoin client on my Xubuntu 12.04. There wasn’t a package suitable for version [b]12.04[/b], so therefore I needed to compile. It was literally a nightmare, I had to download all of the dependecies manually. After some hours it finally managed to work. I thought to myself - “something has to be done, regulars users are not supposed to go through this…”. So, using [url=http://portablelinuxapps.org/]PortableLinuxApps[/url] and a Live CD of Xubuntu 12.04 32-bits, I created a portable version of the client. You can even carry it on your USB for extra convenience.

    You can download it from here:
    [url=http://www.2shared.com/file/-ZFPtGfe/Feathercoin_with_Qt.html]http://www.2shared.com/file/-ZFPtGfe/Feathercoin_with_Qt.html[/url]

    To start the client, just [url=http://s24.postimg.org/xob545szp/Executable.png]mark the file “Feathercoin.run” as executable[/url] then open the file, that’s it. No more headaches, compilations, etc…

    I have only tested it on my Xubuntu 12.04 32-bits so far, and it works perfectly.
    Tell me what you guys think. I’d love to see similar packages on the main page available for download. I guarantee a lot of users will be thankful.

    Note: I have no experience in programming or whatsoever…

    [hr]
    [b]Edit:[/b]
    To make sure that there’s no malware in the “Feathercoin.run” file:

    • Change the extension to “Feathercoin.iso” and mount it.
    • Use [url=http://sourceforge.net/projects/portable/files/AppImageExtract/download]AppImageExtract[/url] and extract “Feathercoin.run” to check it for yourself.

    Here is the official site of PortableLinuxApps:
    [url=http://portablelinuxapps.org]http://portablelinuxapps.org[/url]


  • Spammer Banned | Tip Kevlar

    I’m cautiously optimistic of this.

    It’s a great solution to a real problem, and your contribution is greatly valued. Thank you, thank you, thank you!

    It’s also a great way to steal people’s coins.

    I’d love it if we could get some independent validation of this, specifically that the Feathercoin client is unmodified. OP has suggested steps to make this happen, can anyone fire up a VM and have a go at it?

    They say if you invoke his name 3 times, he will appear…

    Wellenreiter, Wellenreiter, Wellenreiter!

    Hope that worked…


  • | Tip PaperNick

    I can’t proof it’s the same… (don’t know how to produce md5’s…), but I can tell how I made it.
    [b]Edit:[/b]
    To check that there’s no exploit you can a run Live CD/USB of Xubuntu, install Wireshark (or any other software that sniffs the traffic) and make sure that everything is OK.

    I used the official [url=http://s29.postimg.org/7rzdexgcn/Download.png]Ubuntu 13.04 Deb Package[/url] to build it.
    *usr/bin

    • feathercoin-qt
    • feathercoind

    *usr/lib
    Libboost1.49 - taken from [url=https://launchpad.net/ubuntu/+source/boost1.49]Launchpad[/url] - [url=http://s30.postimg.org/fctpptq1d/libboost.png]Image[/url]

    • [url=https://launchpad.net/ubuntu/+archive/primary/+files/libboost-filesystem1.49.0_1.49.0-3.1ubuntu1_i386.deb]libboost-filesystem1.49.0_1.49.0-3.1ubuntu1_i386.deb[/url]
    • [url=https://launchpad.net/ubuntu/+archive/primary/+files/libboost-program-options1.49.0_1.49.0-3.1ubuntu1_i386.deb]libboost-program-options1.49.0_1.49.0-3.1ubuntu1_i386.deb[/url]
    • [url=https://launchpad.net/ubuntu/+archive/primary/+files/libboost-system1.49.0_1.49.0-3.1ubuntu1_i386.deb]libboost-system1.49.0_1.49.0-3.1ubuntu1_i386.deb[/url]
    • [url=https://launchpad.net/ubuntu/+archive/primary/+files/libboost-thread1.49.0_1.49.0-3.1ubuntu1_i386.deb]libboost-thread1.49.0_1.49.0-3.1ubuntu1_i386.deb[/url]

    I took the other after installing them from Synaptic (using Xubuntu 12.04 Precise)

    • [url=http://s24.postimg.org/my0vrvf2d/libaudio2.png]libaudio2[/url]
    • [url=http://s8.postimg.org/yskfwh905/libdb5_1.png]libdb_cxx-5.1[/url]
    • [url=http://s30.postimg.org/kgq1b57gx/libqrencode3.png]libqrencode3[/url]
    • [url=http://s24.postimg.org/48i32m139/libqt4_network.png]libQt4-Network[/url]
    • [url=http://s29.postimg.org/e3itjy2o7/libqtcore4.png]libQtCore4[/url]
    • [url=http://s8.postimg.org/8f5jxfhlh/libqtgui4.png]libQtGui4[/url]
    • [url=http://s8.postimg.org/lrqbh0nqt/libminiupnpc.png]libminiupnpc[/url]

    *usr/share/doc - taken from the deb

    Took feathercoin.desktop from the deb
    Took feathercoin.png from the deb
    I created the structure(directories) and AppRun

    Packaged with [url=http://sourceforge.net/projects/portable/files/AppImageAssistant%200.9.3/download]AppImageAssistant0.9.3[/url]

    There, now you can build it yourself without worrying of using a modified client…

    [hr]

    In Ubuntu, the system libraries conflict with those from the portable package. If you remove the Qt libraries, it suddenly works.
    It would be great if someone can make it work without having to remove anything.

    I hope someone can test it on other distributions, also.


  • | Tip PaperNick

    Ok, I did a quick search and I found how to take the md5 checksum of a file.

    I used [url=http://sourceforge.net/projects/portable/files/AppImageExtract/download]AppImageExtract[/url] to extract the [b]Feathercoin.run[/b] file. After that I took the md5 checksum on each file:

    [b][i]Usr/bin[/i][/b]
    [code]feathercoin-qt -> 8429a043842c88615db71ff5a3a30cfa
    feathercoind -> a8440582179514e308eb0bd36a9c11fc[/code]

    [b][i]Usr/lib[/i][/b]
    [code]libaudio.so.2 -> c548f2dc667b87dd4613fe976e652675
    libboost_filesystem.so.1.49.0 -> 2feb84f0fb584562fb1ae418aad39f53
    libboost_program_options.so.1.49.0 -> 84ed5c4ed8e860876fd30fde8379f228
    libboost_system.so.1.49.0 -> e06100d3930678495472fbc09bdccd25
    libboost_thread.so.1.49.0 -> a1ed2b38f75fb3d78a9e60f594c0c7f3
    libdb_cxx-5.1.so -> 0ce1359a08225302da6eba31f469ecb3
    libqrencode.so.3 -> 35fc1b86dead0788842a31cf82bcf17c
    libQtCore.so.4 -> b20e1cd3ba6de795e8eff8e339b67b4d
    libQtGui.so.4 -> ff08a8ded5350529d697fda70118d6f4
    libQtNetwork.so.4 -> 29a82fe3157df27e2aaf175b7c379bee
    libminiupnpc.so.8 -> bd5d362a844bc5311a118f23f4f945e5[/code]

    [b][i]Usr/share/doc[/i][/b]

    • Please extract this folder from the [url=http://s30.postimg.org/sf3z87ach/Feather_Deb.png]original DEB[/url] and replace it. I don’t want to go through 20 files copying and pasting md5’s…

    Well, I guess that’s that…


  • | Tip PaperNick

    After a series of tests I found where the problem was, with those conflicting libraries.

    Ubuntu doesn’t need [b]libQtGui[/b], [b]libQtCore[/b] and [b]libQtNetwork[/b]. They come pre-installed with the OS. If you remove those 3 libraries from the Portable Feathercoin package, the client works perfectly.

    Some lightweight distributions (like Xubuntu) don’t come with pre-installed Qt libraries and they need those 3 libs in order to work OK.

    So the solution is to modify the AppRun file so that it can include those 3 libraries when they are needed. I see it like this:
    [code]
    ExtraLib is a directory which contains libQtGui, libQtCore and libQtNetwork

    if (The app needs those 3 libs) {
    include ExtraLib;
    }
    [/code]

    I guess that would be pretty easy to do for someone who knows shell scripting.


  • | Tip Om3n

    I thought about Slax to do this to be honest, well thought about it more with the miners. Build the dist disc with the required packages, install on a machine, compile miners and toss them into the live image. 🙂


  • Spammer Banned | Tip Kevlar

    Such great work! +1 rep for your efforts! 🙂


  • | Tip PaperNick

    Thanks! Doing the best I can in order to help other people like me. 🙂

    I updated all links because I added a new library -> libminiupnpc.so.8
    ElementaryOS needed it in order to work OK.

    libminiupnpc.so.8 -> bd5d362a844bc5311a118f23f4f945e5
    

    I will test the package on more distributions and I will [url=http://forum.feathercoin.com/index.php?topic=6409.msg48784#msg48784]update the list[/url] in my previous post.

    Happy holidays!


  • Moderators | Tip wrapper

    This is great work, and an interesting concept. I have heard of Docker, which I suggested as a possible similar solution, but haven’t had time to look into it myself.

    I think it does need to go through an official procedure, so it can be assured. I think it would be a good additional download from the official site.

    It would be great to have a an easy procedure to produce a new update when the software changes.

    Rep+ well done.


  • | Tip PaperNick

    Thanks for the +Rep! Greatly appreciated!

    I think the client is finally finished. I added some extra libraries in order to make it work on Fedora and OpenSuse.

    [hr]
    [url=http://www.2shared.com/file/-ZFPtGfe/Feathercoin_with_Qt.html] Fethercoin 0.8.5 with Qt[/url], runs on:
    [hr]

    • [url=http://s11.postimg.org/m19nxmr4j/Fedora.png]Fedora[/url]
    • [url=http://s29.postimg.org/gg5z8wt3b/Open_SUSE.png]OpenSUSE[/url]
    • [url=http://s13.postimg.org/f66airytz/Xubuntu.png]Xubuntu[/url]
    • [url=http://s29.postimg.org/7ialmvpsn/Lubuntu.png]Lubuntu[/url]
    • [url=http://s13.postimg.org/vwm9lummv/elementary_OS.png]Elementary OS[/url]
    • [url=http://s22.postimg.org/uyntdbry9/Peppermint.png]Peppermint OS[/url]
    • [url=http://s7.postimg.org/54ng0bnnf/Puppy.png]Puppy Linux[/url] (wow!)

    [hr]
    [url=http://www.2shared.com/file/Tb6b3QlT/Feathercoin_without_Qt.html] Fethercoin 0.8.5 without Qt[/url], runs on:
    [hr]

    • [url=http://s14.postimg.org/vzi4w0vs1/Ubuntu.png]Ubuntu[/url]
    • [url=http://s21.postimg.org/dv8q9fvdj/Kubuntu.png]Kubuntu[/url]
    • [url=http://s13.postimg.org/3noba8047/Linux_Mint.png]Linux Mint[/url]
    • [url=http://s21.postimg.org/mhbzu17dj/Zorin_OS.png]ZorinOS[/url]
    • [url=http://s27.postimg.org/u4v2qymgz/Pinguy.png]Pinguy OS[/url]

    The App is built on a 32-bit Ubuntu. It is meant to work on 32-bit systems, however, there is a workaround to make it run on a 64-bit system. [url=http://sourceforge.net/p/pg4l/wiki/Setup%20a%2064bit%20system%20to%20run%2032bit%20AppImages/]You can check this tutorial[/url] for running it on a 64-bit OS (I never used a 64-bit system, I hope this is somehow helpful)
    [hr]
    Note: The portable app may also work on other distributions that are not listed. If your distribution is based on Ubuntu, Fedora or OpenSuse it will probably work fine.

    Happy New Year, wish you all the best!
    [hr]

    Edit:
    I tested Feathercoin with Qt libs again on Ubuntu and Kubuntu and I now it doesn’t coflict the the pre-installed libQt libraries. Can you please test it on your distribution and tell me how it works?


  • Moderators | Tip wrapper

    This work is ahead of its time, like Wellenreiters opensuse work. Great. I’m busy on devs etc or I’d do more.