Feathercoin daemon and wallet production version

[Solved] Incorrect or no genesis block found

  • | Tip mindcandyman

    Hi everyone! I am very new to feathercoin mining (and cryptocurrencies in general). I have been mining for the past couple of weeks and everything has been great. I recently tried to open my feathercoin wallet (version 0.8.5) and I received this error (I’m on windows 7 64 bit):

    “Incorrect or no genesis block found. Wrong datadir for network?”

    I tried uninstalling the wallet program and reinstalling it, but I still get the same error. I’m not quite sure what to do. I did backup my wallet dat file earlier but my most recent mining dump didn’t make it I don’t think. So that is probably lost.

    If anyone could provide any help I would greatly appreciate it. I’m new to all of this so I hope my lack of knowledge won’t be exasperating. Thanks!

  • | Tip mindcandyman

    I took a shot at fixing this myself and tried a couple of things and it worked! I wanted to post the information up here in case anyone else had the same issue. What I did was delete all the .dat files under the block folder (in c:/users/*****/app data/roaming/feathercoin). I restarted the program and it started synching again, but I received some errors along the way. I realized that I didn’t have my wallet encrypted so I did that and restarted. Then it worked perfectly. Hopefully this will be helpful to someone having the same issue.

  • Team Infrastructure | Tip ChekaZ

    Thanks for your fixing help post! 🙂 Appreciate that. If your Client is stuck and doesnt load or shows errors maybe it just helps to delete the /roaming/feathercoin folder. (Dont forget to backup your wallet first!) - The client will automaticly recreate this folder and start to download the blockchain again. That should always work.