Feathercoin daemon and wallet production version 0.17.0.1

[Solved] v0.8.6.1 stuck at block 33,582 for many


  • Regular Member | Tip Drjones

    Installing Fresh .0.8.6.1 on pc and getting stuck on block 33,582?

    Have reinstalled twice today but keeps stoping at this block and will not go further any ideas?

    Thanks


  • | Tip arthurus

    Installing Fresh .0.8.6.1 on pc and getting stuck on block 33,582?

    Have reinstalled twice today but keeps stoping at this block and will not go further any ideas?

    Thanks

    I apologize if this isn’t the right place for this but I’m having the same problem. I downloaded 0.8.6.1 to update my wallet and this happened. I even deleted the blockchain to re-download a new one and had the same problem.

    I also tried installing the wallet fresh on a totally different computer that I don’t use for mining, and have the same problem. It took a few minutes to get up to block 33582, last block time: Sat Jun 8 10:15:42 2013, then does nothing, it gets stuck there.

    I’ve left it sit there for 8+ hours and it still hasn’t advanced.

    debug.log on both computers is full of things like:

    2014-04-13 00:26:33 ERROR: CheckProofOfWork() : nBits below minimum work

    2014-04-13 00:26:33 ERROR: CheckBlock() : proof of work failed

    2014-04-13 00:26:33 ERROR: ProcessBlock() : CheckBlock FAILED

    and

    2014-04-13 00:28:50 ERROR: AcceptBlock() : block’s timestamp is too early

    2014-04-13 00:28:50 ERROR: ProcessBlock() : AcceptBlock FAILED

    and

    2014-04-13 00:34:41 ProcessBlock: ORPHAN BLOCK

    2014-04-13 00:34:41 ERROR: CSyncCheckpoint::CheckSignature() : verify signature failed


  • | Tip PolybiusSquare

    v0.8.6.1 Client will not sync past block 33,582

    I have done all the usual tricks to get it moving and all have failed. I have asked my Feathercoin group and everyone that re-installed the client is stuck here as well.

    I’ve watched it sync to 33,582 about 15 times on fresh installs/some different machines which takes only a few minutes, but then it immediately throws the following over and over again:

    ERROR: AcceptBlock() : block's timestamp is too early
    ERROR: ProcessBlock() : AcceptBlock FAILED
    ERROR: ProcessBlock() : CheckBlock FAILED
    ERROR: CSyncCheckpoint::CheckSignature() : verify signature failed
    ERROR: CheckProofOfWork() : nBits below minimum work
    ERROR: CheckBlock() : proof of work failed
    ERROR: ProcessBlock() : already have block XXX

  • Moderators | Tip wrapper

    Cheers for reporting that. Looks like an early hard fork is causing a problem. That may be due to tightening the block criteria, or some such.

    Certainly needs looking at quick. I’ll message Peter he needs to look at it ASAP.


  • Moderators | Tip wrapper

    It would help Peter to investigate this - to see the Debug.log entries show any further detail.

    Debug is in users appdata in Windows or .feathercoin in Linux.

    If any one can have a look, post any relevant messages…


  • Moderators | Tip Wellenreiter

    As a workaround:

    If you have the .feathercoin directory from the 0.8.6.0 client you can work on this one and get past the problem.

    I copied the .feathercoin form my 0.8.6.0 installation to the 0.8.6.1 installation and my client is synced now.

    Under Linux the directory is $HOME/.feathercoin and with windows it is user\appdata\roaming\feathercoin or %appdata%\feathercoin


  • | Tip lizhi

    Are you sure that feathercoind need to reinstall ? FTC pool must git and compile code again ?


  • Moderators | Tip wrapper

    Lizhi, you will need to reinstall, the old client will not work after the Hard Fork.

    Wait till we find what this “sync bug” is first, though.


  • | Tip arthurus

    Getting stuck on block 33582

    block time: Sat Jun 8 10:15:42 2013

    Isn’t that the date there was a 51% attack on feathercoin?

    Could that be the cause of getting stuck at that point, or is it just a coincidence?


  • | Tip PolybiusSquare

    All sync issue post mopped into support thread here https://forum.feathercoin.com/index.php?/topic/6946-v0861-stuck-at-block-33582-for-many/

    I have sent PM’s to users to inform them

    UM

    Uncle, Thank you for merging posts to my thread

    It would help Peter to investigate this - to see the Debug.log entries show any further detail.

    Debug is in users appdata in Windows or .feathercoin in Linux.

    If any one can have a look, post any relevant messages…

    Is it safe to post/attach the entire debug log here or should I PM it to someone?

    I upgraded without any problems. Wonder why this happened to so many people… What version of wallet you guys had before this upgrade?

    It’s fresh installs mostly - not everyone keeps an up to date chain (cold storage ect)


  • administrators | Tip uncle_muddy

    I’ll stand a new machine up tomorrow morning and dump to the debug.log and get it posted.


  • | Tip MMs

    +1 Same here… Got the solution though 🙂

    It’s a problem in the latest version, changed enum { nMedianTimeSpan=11 }; to enum { nMedianTimeSpan=13 };

    and apparently broke it.

    Either get the previous version or recompile with that change reversed, until devs fix this.

    this guy discovered it today:

    https://bitcointalk.org/index.php?topic=568748.0

    Cheers,

    MM


  • | Tip Bushstar

    I will get on to this now and release an updated version when I have the fix.


  • | Tip Bushstar

    Apologies for not picking this up sooner. I am away in Germany with my family so am not as on the ball as I normally would be. I have replicated the problem and will now work on the fix.


  • | Tip Bushstar

    The problem is what was reported on BitcoinTalk. That makes things a bit quicker to resolve. The change has been put on to GitHub and you can download the latest Windows client from the link below.

    https://downloads.feathercoin.com/feathercoin-setup-0.8.6.2.exe

    I am compiling the Mac client now.


  • administrators | Tip uncle_muddy

    is the move to 0.8.6.2 required?


  • | Tip Bushstar

    Only if you need to do a full sync of the blockchain. If you already have the blockchain downloaded then you do not need to have this version.


  • Regular Member | Tip Drjones

    Good work on fast update, will download later get things synced up.


  • | Tip PolybiusSquare

    The problem is what was reported on BitcoinTalk. That makes things a bit quicker to resolve. The change has been put on to GitHub and you can download the latest Windows client from the link below.

    https://downloads.feathercoin.com/feathercoin-setup-0.8.6.2.exe

    I am compiling the Mac client now.

    Thanks for the quick resolution! Going to try it out now.