Feathercoin daemon and wallet production version 0.18.1
Old daemon and wallet version 0.17.0.1

[Solved] GPU mining rig issues. 4 GPU's that ran together before, won't now.


  • Regular Member | Tip slowhash

    Long story made short, I have 4 gpu’s (2 sapphire 290 and 2 xfx 290x) that were running together on a different motherboard, but on this mobo will freeze when the AMD drivers are loaded. The mobo will run when the windoz drivers are loaded got the cards. Tried with 13.11, 13.12, and 14.9 drivers.

    Here’s the weird part, only 3 gpus shot in windoz either way.

    The long story…

    I bought a gaming rig, and made a miner… Asus SABERTOOTH_990FXGEN3_R20 mobo, 280x video, 8350 black cpu, 16gb ram.

    Upgraded the GPU to 2 Sapphire GPU’s and it ran.

    Moved the mobo out of the case to the wooden shelf in my avatar, added another PSU, 2 XFX 290X GPU’s and 4 extension cables, and it ran. (my avatar is a pic of that rig)

    At this point, I had PSU #1 running the mobo and 2 GPU’s, and PSU #2 was just running 2 GPU’s, but it had the IDE connectors on all 4 extension cables on it. It ran fine like this for about a month.

    PSU #2 started browning out (but I hadn’t figured that out yet) and causing crashes to the rig. One day, I smelled that hot small of plastic cooking and shut down the rig to investigate. The mobo power connector had cooked, the PSU # 2 failure overdrew the mobo connector.

    So I ordered a new mobo (Gigabyte GA-990FXA-UD3) and PSU #3 (1100 watt gold), and a couple g-blade asic miners. And PSU #2 I researched into and found out it had issues, so it’s in the scrap bin.

    Since then, I have been running only 2 GPU’s (the sapphires) and the new mobo and asics, off GPU #3.

    Now I want to run the 2 XFX GPU’s again, so I take PSU #1 (with the fried connector) and hook it to those GPU’s. They all power up correctly, and I read 12v at all the yellow wires… But, windows locks up, right after the windows screen.

    Boot to safe mode, run DDU, reboot and let windoz drivers load, and it runs fine but only shows 3 GPU’s. (1 sapphire and 2 XFX)

    Will reboot as many times as I try it, but not mine.

    Load ATI drivers, and it will freeze up solid right after the next login screen. Tried it with the XFX cd, the Sapphire CD, 13.11, 13.12, and 14.9 drivers, all running DDU between. Most of them twice.

    Mobo should be able to run 5 cards (add 1 more card on the pcie1 slot), and has the latest bios.

    Ideas?

    -edit- I swapped the 2 XFX for the 2 Sapphires and it runs with just them, so 2 will run at a time but not all 4 GPU’s at once.


  • | Tip rynomite

    What type of riser cables are you using? 16x to 16x and maybe a single 16x to 1x? Almost every single problem that I’ve ever had with mining has been related to crappy riser cables. Pins that aren’t completely soldered, tiny breaks in the ribbons themselves etc. I’ve tossed about 5 different cable in the last year alone. In retrospect I should have just taken a dremel to them and reduced them to 16x to 1x…

    Here are a few observations that I’ve made over the last year in regard to these risers…

    First off, if I could start all over I would have done all 16x to 1x ribbons. Mining doesn’t use anything other than 1x anyway, they are cheaper, and you have less pins to be messed up or broken (less troubleshooting basically). Not only that, but when you have a 16x ribbon in a 16x slot (especially the first 2 slots), the motherboard reports this, the OS expects this, and the AMD Catalyst software tries to utilize it. What appears to happen is that the AMD software will try to enable crossfire automatically as soon as it detects 2 16X or 8X devices in those first 2 slots. If any single pin is messed up in the 1x, 4x, or 8x sections of either of these risers, the driver will lock the system up and cause it to crash. I’ve been able to take bad cables and move them to the last slot simply because that last slot only tries to utilize 4x which doesn’t use the majority of the riser pins and it magically works just fine.

    Like I said, almost every single problem I’ve ever had was PCIE riser related. As soon as I take the riser out of the equation, everything magically works just fine. Go figure. The magic about using all 1x risers is that the Catalyst driver theoretically should never try to enable crossfire or use anything beyond that 1x bandwidth. If you’ve got mostly 16x risers, I would move them around and see if you can’t get 2 good ones into the PCIE 1 and 2 slots. If you can get those first 2 slots working well and mining, you should be able to start adding more cards to the system. If you add card 3 with another 16x riser and the system locks up, most likely you’ve got a riser with an issue in the 1-4x range.

    Cheers.


  • Regular Member | Tip slowhash

    That is something I will definitely look into, as I have a couple cables that I’m not using, to swap out…

    Thanks for the tip!! 🙂


  • Regular Member | Tip slowhash

    Finally got around to dinking with it, and you nailed it…

    Aced one of the 16x to 16x cable and replaced with a 1x, and mining away with that GPU now…

    Just need to get some more 1x cables to replace the others and I’ll have all GPU’s running happily.

    Thanks, I owe you a beer!!


  • | Tip kris_davison

    Marked as solved 🙂


  • Regular Member | Tip slowhash

    Yes, solved!!!

    Got new 1x/16x cables in, swapped out all but but the GPU with monitor attached to teh new cables, and 4 happy GPU’s!! That makes me a happy camper too!!


  • Regular Member | Tip slowhash

    FYI, now that I know that the cables can be problematic, I ordered from this place on ebay… http://www.ebay.com/itm/331281827101 Us based, cheap, fast ship, and received 6 when I bought 5.

    And the important part, I used 3 so far and they all worked with no issues!


Log in to reply