Supported Feathercoin client versions: Current production Version: 0.13.1.

Info: If you have problems to post, create one post in the ‘newbies’ category and try again. If you have further problems, find support under Guides or use the shoutbox

What to do if your Wallet database is incompatible?


  • Moderators

    One of the problems with Bitcoin development has been what to do about upgrading when you need backward compatibility?

    We have just come across an issue where current version won’t compile on Ubuntu 14.04 because of issues moving to Qt3.

    Another difficult area for Bitcoin and therefore Feathercoin, is the Wallet database where many distributions and PPA builds of the software use an old database, Berkley 4.8, whereas others have moved of to Berkley 5.1 or Level BDB …

    https://www.mail-archive.com/[email protected]/msg07491.html

    Excerpt from Canonicals reasons for dropping the Bitcoin Software centre support

    Additionally, there are other issues with the packaging process. Bitcoin,
    as of version 0.8.0, switched the blockchain indices from using Berkeley DB
    to using LevelDB. However, BDB is still used in the bitcoin wallet. All
    upstream release binaries are built using BDB version 4.8. The only version
    of Ubuntu which includes this version of BDB in its repositories is Lucid.
    Later versions build their Bitcoin packages with BDB 5.1. The problem with
    this is that BDB databases are not backwards-compatible with older versions
    of BDB. Any bitcoin wallet that is touched (created, or even once opened)
    by a Bitcoin binary built with a version later than 4.8 will become
    impossible to open with any Bitcoin binary built with an earlier version,
    which as mentioned includes the vast majority of Bitcoin binaries used on
    other platforms. This means that the wallet is not portable between
    platforms as is expected, and the error message is not one that clearly
    indicates the problem, as the failure originates in BDB and not the Bitcoin
    software.

    I currently am on Berkley 5.1 dB, however I did not seem to have any trouble using the latest Feathercoin PPA?
    Is there an easy test what database I am on?

    If I did have trouble wallet database compatibility issues, what could I do?

    One option would be to extract the private keys, then input them back into a reinstalled, standard wallet.

    Any other ideas?

    i.e why can’t data be copied back to old database format?


  • Regular Member

    It’s possible technically to downgrade a Berkeley DB to an older format using their command line tools. I build wallets with v5.3.28 currently. v6 is the AGPL v3 which might cause legal issues with the BSD/MIT software.


  • Moderators

    @ghostlander said:

    It’s possible technically to downgrade a Berkeley DB to an older format using their command line tools. I build wallets with v5.3.28 currently. v6 is the AGPL v3 which might cause legal issues with the BSD/MIT software.

    Thanks for the update.


 

Looks like your connection to Feathercoin Forum was lost, please wait while we try to reconnect.