Supported Feathercoin client versions: Current production Version: 0.16.1.

Old Production Version: 0.16

Info: If you have problems to post, create one post in the ‘newbies’ category and try again. If you have further problems, find support under Guides

Database read error with Wallet 0.8.7 and Windows


  • Moderators



  • Hi,

    I have a annoying issue with my wallet on Windows, (0.8.7) I got too often database reading error, and I need to downloadall the blockchain over an over…

    Do the 0.9.6 release fix this issue ? Any link or how to compile for windows available ?

    Thanks in advance,
    Best,
    Looarn


  • Moderators

    @looarn
    Honestly I don’t think, that it is a problem of the wallet code, as the 0.8.7.x versions of the wallet are out for a while now, and no such problem has been reported.
    But you really using Wallet version 0.8.7?

    That version is outdated and will not work correctly.

    The latest 0.8.x version is 0.8.7.3 which contains some important fixes.

    You can download the compiled 0.8.7.3 wallet from here

    To update

    • export and backup your private keys to a safe location
    • shutdown your old wallet
    • copy the downloaded binary into the directory of your old wallet
    • start the new wallet and let it sync

    Please tell us, if the problem is solved with the update



  • Hi Wellenreiter,

    Thanks a lot for your assistance.
    Yes I use 0.8.7.3 on Windows Seven 64Bits.

    I did the “re-install” think like 3 time this week.

    And here is the debug.log :
    2016-11-01 09:21:25 Feathercoin version v0.8.7.3 (Mar 9 2016, 21:35:08)
    2016-11-01 09:21:25 Using OpenSSL version OpenSSL 1.0.1s 1 Mar 2016
    2016-11-01 09:21:25 Default data directory C:\Users\USER\AppData\Roaming\Feathercoin
    2016-11-01 09:21:25 Using data directory C:\Users\USER\AppData\Roaming\Feathercoin
    2016-11-01 09:21:25 Using at most 125 connections (2048 file descriptors available)
    2016-11-01 09:21:25 Using 2 threads for script verification
    2016-11-01 09:21:25 init message: Vérification du porte-monnaie…
    2016-11-01 09:21:25 dbenv.open LogDir=C:\Users\USER\AppData\Roaming\Feathercoin\database ErrorFile=C:\Users\USER\AppData\Roaming\Feathercoin\db.log
    2016-11-01 09:21:25 Bound to [::]:9336
    2016-11-01 09:21:25 Bound to 0.0.0.0:9336
    2016-11-01 09:21:25 init message: Chargement de l’index des blocs…
    2016-11-01 09:21:25 Opening LevelDB in C:\Users\USER\AppData\Roaming\Feathercoin\blocks\index
    2016-11-01 09:21:28 init message: Chargement de l’index des blocs…
    2016-11-01 09:21:28 Wiping LevelDB in C:\Users\USER\AppData\Roaming\Feathercoin\blocks\index
    2016-11-01 09:21:28 Opening LevelDB in C:\Users\USER\AppData\Roaming\Feathercoin\blocks\index
    2016-11-01 09:21:29 Shutdown : In progress…
    2016-11-01 09:21:29 StopNode()
    2016-11-01 09:21:29 ERROR: CAddrman::Write() : Rename-into-place failed
    2016-11-01 09:21:29 Flushed 0 addresses to peers.dat 2ms
    2016-11-01 09:21:29 Shutdown : done

    Also I read that when I shutdown the wallet it can take a while, on my system it’s close very quickly, like an hard shutdown, maybe this broke the batabase, when I quit the wallet ?

    Anyway I would like to install the 0.9 version, any guide on how to ?

    Best,

    PS : the “ERROR: CAddrman::Write() : Rename-into-place failed” is a known issue in both feathercoin and litecoin wallet.


  • Moderators

    I’ve never had the Rename-into-place failure. I only use Linux, so I think it is a windows related bug.

    I’m trying to get a 0.9.3.x Wallet for windows for you. Unfortunately I can’t compile for windows myself.

    I’ll keep you updated

    By the way, the 0.8.x versions of the wallet shut down quite fast, while the 0.9.x versions take a bit of time to shut down. the reason is that the 0.8.x versions simply exit the program, while the 0.9.x versions creaet some backup before the exit.



  • @Wellenreiter said in [Database read error with Wallet 0.8.7 and Windows]

    By the way, the 0.8.x versions of the wallet shut down quite fast, while the 0.9.x versions take a bit of time to shut down. the reason is that the 0.8.x versions simply exit the program, while the 0.9.x versions creaet some backup before the exit.

    This is exactly the issue I think. Should solve this problem. 🙂

    I can do the compilation, just need an “how to” guide. 😉

    Thanks for your time.


  • Moderators

    Mhhh, I don’t have any experience with the windows compile.

    May be you can handle it, but the only description I have is the one on Github.

    So my recommendation only can be:

    It looks like nobody did a native windows compile, but it’s cross compiled using mingw

    Sorry, that I can’t be of more help



  • Hey thanks,

    I’ll try this and report here. 🙂

    I use Ming by the past should be smooth. 🙂

    Thanks a lot for your time.


  • Moderators

    Hi @looarn

    is this solved, so I can flag it s answered?


  • Moderators

    I personally feel this thread can be closed. My reasons…

    • The version in question is 0.8.7.3 - Windows, 64BIT. That version is no longer the production version and no longer works with 0.9.6.

    • 0.9.6 Windows binaries and setup files have been uploaded to the official Feathercoin GitHub page.
      https://github.com/FeatherCoin/Feathercoin/releases and are confirmed as working and virus free