Feathercoin daemon and wallet production version 0.17.0.1

Question about a 2nd GPU


  • Moderators | Tip Wellenreiter

    No, you don’t need a second batch file, the use of the GPUs is configured in the ccminer config file.
    what you can try:

    • locate the ccminer.conf file. It normally is located somewhere under %appdata% and edit it manually
    • when running ccminer from a command line window there should be a menu item like ‘gpu management’ or similar, where you can configure the GPU usage.

    I’m not using ccminer, so others may be able to provide more specific advise


  • | Tip jimmy24651

    I’ll give it another shot when I get back home this evening. Thank you for the timely response! You guys are the best!


  • | Tip jimmy24651

    Ok. I’m back at this thing. I didn’t want to shut the machine down, and stop a good thing from working, so I have been dragging my feet.

    I now have both of my card installed, and running.

    I am using Open Hardware Monitor, and it is showing both cards, so it is clear that they are both functioning properly with my system, but none of the command I have tried adding to my batch file will get them both mining simultaneously.

    I have tried adding “-t 2”, “-n 0,1”, “-d 0,1”, and every combination of all of them, and no matter what I try, I can only get hashing from one of the cards.

    Do you know of anyone in particular that we could tag on this post that may be able to help? I would REALLY love to get these 2 going!


  • Moderators | Tip Wellenreiter

    There are several posts about mining with multiple GPU here in the forum, but most of the rigs described are AMD based.
    I know, that @AmDD has run a multi GPU rig in the past, but that was AMD based also.

    The only thing I can suggest besides a search for ‘NVIDIA’ here in the forum in order to get the names of NVIDIA users is to contact the developer of your mining software on github, or open an issue for your problem on Github.
    I hope at least the developer can tell if the software can handle multiple GPU and how to ge it working.

    You also could try to use another miner.

    When I was mining on my Nvidia card I used cudaminer (https://github.com/cbuchner1/CudaMiner)

    cudaminer is able to use several GPU and is actively developed.
    CBuchner is very responsive to bugs or problems reported.


  • | Tip jimmy24651

    I got it running last night. I tried adding all of those different command lines, but I didn’t realize that I already had a -d command at the very end of my batch. HA! Basically, I was telling it to look for multiple cards, but then, at the end of the file, telling it that there was only one.

    Sometimes I really crack myself up…what can i say? I’m still learning.

    The good thing is, they are both working great, and have been since I went to bed last night!


  • Moderators | Tip Wellenreiter

    Glad that you got it working 🙂


  • Moderators | Tip wrapper

    Well done, problem solving.


  • | Tip lcr11

    @jimmy24651 said in Question about a 2nd GPU:

    ccminer.exe -a neoscrypt -q -t 2 -o (pool info) -u (worker info) -p (password) -d 0

    jimmy, I’ll be downloading CCminer when I get home and I’m completely new to this, like, I’m googling every 9th word I see in posts. I have multiple 1070s also. So when you downloaded CCminer you just opened the main file after unzipping, created a .bat file and entered
    "> ccminer.exe -a neoscrypt -q -t 2 -o (pool info) -u (worker info) -p (password) -d 0" into the word document?

    I’m guessing the ‘-d 0’ is telling it that there is only one GPU? what did your final .bat file look like to run multiple GPUs? I’ll be running 4- 1070s right now and 7 when I get the new PSU in. Thank you for all of your help.


  • | Tip jimmy24651

    @lcr11

    I, personally, use ccminer8.14 cuda, but there is another cuda version. I tried everything i could possibly use, and this was the only one i was able to get working with my cards.

    Your batch file looks good, after you delete the -d 0 off of the end. This was the problem i was having. The -t command is telling your machine to look for multiple cards, but the -d 0 is telling it not to. When i deleted my -d 0, everything went smooth. Also, I put a 2 behind my -t because I have 2 cards. Depending on how many cards you have, that number will vary.

    @ghostlander - does that all sound right?


  • | Tip jimmy24651

    PS - sorry for taking so long to respond…its been a busy day!