New release !!!

Supported Feathercoin client versions: Current production Version: 0.13.0.

Info: If you have problems to post, create one post in the ‘newbies’ category and try again. If you have further problems, Find Support under Guides or use the shoutbox

Question about a wallet.conf file



  • Im not sure if this is the correct place to post this question, so if it’s not, feel free to move it.

    In the wallet.conf file, what happens differently if the listen= command is changed from a 1 to a 0, or from a 0 to a 1?


  • Moderators

    it should be “feathercoin.conf” not “wallet.conf”


  • Moderators

    @jimmy24651

    The ‘listen’ directive defines, if your wallet listens for incomming connections on tcp port 9663 or tcp port 19336 for the testnet.

    If it is set to 0, only outbound connections are made.

    Default is listen=1



  • @AcidD - You’re right… I was trying to be politically correct by not stating which coin I was talking about since this is a FTC forum! =o)

    @Wellenreiter - Thanks for the info. This question is actually regarding a coin I recently got into, and I am trying to set up a masternode. No one had compiled a linux version of the wallet yet, so I was attempting to run the MN on my local PC. (I know nothing about linux, other than how to follow a step-by-step guide on how to set up a remote MN on it) Against my better judgement, I went ahead and attempted to get it set up and running on my Windows machine. I have heard that this leaves not only your coins, but your entire home network vulnerable…so I really would prefer to set up a remote MN on a VPS…BUT…I am coming at all of this with limited knowledge, so I kinda got to work with what I have available. After setting up everything, my wallet wouldn’t start. I don’t recall the exact error it was giving me, but when I clicked the ok button to clear the error, another dialogue popped up which said something about changing listen to 0. I went ahead and tried it to see what would happen. The wallet started up, and I was able to “start” the masternode, and get an “enabled” confirmation that it was running, but I never received a payout. Numerous sources told me that I should have gotten a payout in the first 24 hours, and I never did. Due to the fact that I was already hesitant to run this MN on my PC, I went ahead and shut it down. I can’t help but wonder whether the reason I wasn’t receiving any payouts was because I changed the listen to a 0…

    If you, or anyone reading this knows much about masternodes, any advice would be greatly appreciated. I have been unable to find much useful help around the community for this coin, unlike FTC.

    Also, if someone has a few minutes and a little know-how would like to compile a linux version of a wallet, I would gladly pay for such a service! Just let me know!


  • Moderators

    Im happy to help out with the linux wallet build…but the guides are very straight forward… are you stuck somewhere ?



  • I don’t even know where to start…I literally know nothing at all about anything but Windows…


  • Moderators

    @jimmy24651 said in Question about a wallet.conf file:

    dialogue popped up which said something about changing listen to 0

    This message often is caused by another process already obtaining the tcp port your wallet is listening to.

    I’m assuming you are not talking about a feathercoin wallet, so what you can do:

    • find the tcp port your wallet is istening on.
    • find the process using the port
    • stop that process and start the wallet.

    OR

    Check if there is a configutation parameter named ‘connect’ of ‘connectto’

    If yes:

    • find one or more IP addresses of another wallet in the Internet
    • add a connect statement for each address you found to your config

    This should bring up some connections to the Block Chain of your coins an the synchronization process and finally you should receive your coins.



  • @wellenreiter said in Question about a wallet.conf file:

    find the process using the port
    stop that process and start the wallet.

    How would I go about doing those 2 things?


  • Moderators

    @jimmy24651

    Not sure for windows, but:

    • open a command window (cmd)
    • type ‘netstat /help’ or ’ netstat --help’
      not sure about the right syntax
    • from the output locate the parameters to
      • show listening ports only (in linux -l) (lowercase L)
      • use numeric values ( in linux -n)
      • show process information ( in linux -p)
    • issue the netstat command again with the parameter you found out
    • locate the line(s) with ‘127.0.0.1:9336’
    • identify the process listened at the end of the line
    • open a process monitor window (strg-alt-del) and select process display
    • right click on the process you found in the first step
    • select stop process

    If that doesn’t work for you I hope some windows guys can help.


Log in to reply
 

Looks like your connection to Feathercoin Forum was lost, please wait while we try to reconnect.