Feathercoin daemon and wallet production version 0.19.1
Old daemon and wallet version 0.18.3

[Support] Mode of Failure Analysis. Part 1 - Faults, Causes and Solutions

  • Moderators | Tip wrapper

    Feathercoind uses the open source Bitcoind protocol to provide a distributed currency network. All of the features of the fundamental client are common to Bitcoind, Litcoind or Feathercoind.

    This is a Mode of Failure analysis of Bitcoin & Litecoin reported faults, from various intermediate versions of the protocol up to 0.8.5.


    As a note, to new members interesting in setting new services or some such, any document or guide for Litecoin or various other scrypt currency can also be adapted to Feathercoin. Even bitcoin setups apply to some extent, especially with wallet and daemon (service).

    There are also some open source application for Bitcoin or Litecoin, yet to be fully converted to Feathercoin so are opportunities still open to members to pursue.

    I will be adding to the fault list and prioritising it as a “list of solutions to the most found problems” . It will include potential faults to look out for or faults with standard solutions, so more members can help new members get going.

    The moderators have also been marking the support questions [solved], so please look to see if your problem is solved first, before posting.

    Feel free to reply with novel solutions.

    Continues in part 2, because thread post size is limited.


    I Can’t Sync the Wallet

    Might need to have him start it with -addnode=x.x.x.x, where x.x.x.x is someone’s static IP. Hopefully someone should be able to share theirs for that purpose…

    A restart of the client sometimes helps, or starting with reindex command

    feathercoin-qt.exe --reindex

    Lost Passphrase, not good

    Try to remember or sorry no known fix we can recommend.

    Memory Leak

    Which version are you using? bitcoind had a memory leak and when the system ran out of memory bitcoind would be shut down by the kernel. You can probably find messages pertaining to OOM problems in the log files.

    My question is: how long do you need to keep Bitcoin-QT / Feathercoin-qt open after issuing a transaction?
    Your client need to broadcast the transaction to your peers and your peers then further relay it to the whole bitcoin network.
    So, you should not close your client immediately (or in a few seconds) after creating the transaction.
    Go to Blockchain explorer to check your address.

    Windows 8.1 Some problems with client, windows stalls, bug fixed.

    Help About Window.

    On that (Help) page it shows version Latest version : 0.8.5
    When I check the help tab/about on the GUI it shows :
    This program uses Qt version 4.8.3

    Check ‘About Bitcoin’ to get the client version. QT is a cross-platform GUI development tool which is used by Bitcoin-Qt to provide the user interface.

    Small transactions go slower

    The ones that are for 1.0 btc are immediately shown on blockchain.info… but the ones for .78xxxxx are not shown and it has been awhile now. Why is that?

    It looks like bigger transactions have higher priority, so little ones will show up later. I think so. If it’s “processed” status, don’t worry, faster or later BTC’s will arrive

    Where is wallet.dat?

    From what I understand, you just need to copy your wallet.dat file (from old computer) to a secure location, before you reinstall QT on the new computer.

    Then copy back your wallet.dat to the new computer, and you should be fine, once the blockchain has finished updating (which can take up to a a long time (weeks), depending on your bandwitdth).

    wallet dat position, where is wallet.dat?

    C:\Documents and Settings\YourUserName\Application data\Feathercoin

    accidentally entered the address into amount


    Failed to write block

    I just tried to start up my qt client for the first time in a couple of weeks, after some hours of downloading the block it’s now giving me the message “failed to write block” and it then closes the application. This is the latest version of the client on ubuntu 13.04.

    Just try to update/reinstall client first without deleting database in .bitcoin folder (%Appdata%).

    I had another computer with an updated block chain, so I just took the wallet off the computer which had the problem and put it onto the computer which was working. Finally I sent the coins over to the electrum wallet as I wanted.

    Rename the old wallet or delete it. Use Addnode on the Help / Debug Console to Add a node on the network with a client that has an un to date wallet.

    e.g. Through Wifi for instance from Desktop with a LAN IP You will download through the LAN.
    if you type

    addnode onetry

    I cannot see qt client window

    QT takes up to 10min to get started, easily… Maybe you should just be more patient.
    task manager and kill the process (check the Network tab, for example).

    Have you tried update/install NET Framework? I have this problem sometimes too, but only if I accidentaly open Litecoin/Bitcoin client two times in row. Try also kill all processes of qt client and start program once again.

    Vanitygen: Generate an address with X characters

    How can I get vanitygen to generate an address with a certain amount of characters - for example 32 or 33?

    $ vanitygen -r “1[A-Z]{8,10}”
    to get 8 to 10 upper case letters A-Z

    $ vanitygen -r “1[a-zA-Z]{8,10}”
    to get 8 to 10 upper and lower case letters a-zA-Z

    and so on

    Can I get a vanity address for Feathercoin?

    Wallet Bug when importing private key

    It doesn’t seem to effect the functionality but it’s weird. I duplicated it on two different computers running OS X 10.9 and v0.8.5-beta.

    After completion the key you just imported shows up in your address book (i.e. like an outgoing address) instead of under receive as incoming address. The coins still show up in your balance but the address is on the wrong screen.

    When you restart the program this corrects itself.

    Can I get a vanity address for Feathercoin?

    Is it possible to automatically split incoming transactions to other wallets?

    Re: Is it possible to automatically split incoming transactions to other wallets?

    I wrote a tool for that: [url]=https://github.com/kazcw/autosend]https://github.com/kazcw/autosend[url]

    [quote] Code:

    python setup.py install

    If you have ~/.bitcoin/bitcoind.conf set, it’ll use that for RPC configuration. Otherwise:

    autosend set bitcoind.password YOUR_RPCPASSWORD
    autosend set bitcoind.user YOUR_RPCUSER (if not bitcoinrpc)
    autosend set bitcoind.host YOUR_RPCHOST (if not localhost)
    autosend set bitcoind.port YOUR_RPCPORT (if not 8332)

    Now you can create a rule:


    autosend create split IN_ADDRESS OUTPUT:proportion OUTPUT:proportion [etc…]

    To execute all rules:

    autosend execute

    This will distribute any funds in the account (as long as it’s over the minimum balance).

    To see more options, like setting a different fee or changing the minimum balance to trigger a send:

    autosend -h
    autosend create split -h

    N.B. fee sets the maximum fee; your client can choose to send less, in which case you’ll just still have the leftover in the account. You won’t need to set a fee unless you are sending to a bunch of outputs.[/quote]

    Does autosend work with Feathercoin?

    My Wallet can’t find an unconfirmed transaction.

    I am having the same problem. The bitcoin was sent over an hour ago. It shows as unconfirmed on blockchain but fails to appear in my wallet.

    you can always check your trasaction ID on blockchain explorer, you will know if the person has received the FTC / BTC …

    How to speed up the syncing process of Bitcoin-QT under Mac OS X Mavericks

    Mac OS X Mavericks introduces a neat feature, which can be troublesome when you try to sync your Bitcoin app. This feature is called App Nap and it basically slows down any app running in the background


    You need to turn this feature off for the Wallet client. Just right-click on the app’s icon, select GET INFO and then check the PREVENT APP NAP feature.

    Transaction does not confirm (even though send with a high transfer (tx) fee)

    Confirmation Warnings : This transaction has a none standard input.

    That is why. You better double spend those coins with a new transaction, cause that one is probably going to get stuck there.

    How It was fix:


    The input script was non-standard due to a bug in the client that generated the transaction (probably happens about once in 256 times). I fixed the signature by hand. The transaction now appears as double spend, but should be confirmed soon (unless someone confirms the first one before).

    Transaction from crytspy /exchange to my wallet confirmed 20 times but never arrived

    What wallet do you use? If Multibit, go to Tools -> Reset Blockchain and Transactions.

    Can you use Feathercoin with multibit?

    Error Decrypting Wallet? -Blockchain.info Wallet -

    I was typing the correct password, but every time it is showing the message: Error Decrypting wallet - Check your password.

    I have to restore from backup every time I want to login?

    Edit: I restored from backup for the second time. The login is working (as of now).

    Public key is visible

    just wondering is it wise to use a wallet that the public key is visable on the block chain?

    I have been using the same wallet for receiving / sending bitcoins and also to store my bitcoins, I do however have my wallet encrypted.

    There’s nothing wrong with re-using a public address if you are not interested in privacy. Your private keys are never exposed unless you publish them by some outside means.

    Not to worry - everyone’s public addresses are visible to all, once they’ve been used. It’s the private keys that allow sending coins.

    Signing Transaction Failed

    I’m trying to transfer my btc but first i get the error Signing Transaction failed, when I press ok i get another error saying transaction creation failed.

    You’ll need to provide a bit more information to get help with this - for a start what client or web wallet are you using?

    You could try a -rescan, though I doubt that will do anything.
    You could try Armory, which will give you more details.
    You could try extracting the keys and importing them in another wallet.
    You could try importing the wallet.dat in blockchain.info ([url]=https://blockchain.info/wallet/import-wallet]https://blockchain.info/wallet/import-wallet[url])

    Re: Signing Transaction Failed

    Go to help=>Debuging Window=>Console and type


    Find one with an “amout” value big enough for your needs, copy the corresponding txid.
    Go to blockchain.info, and paste the “txid”
    Check the public address of yours that received the funds, copy it.
    Back in the console of QT (you may need to use walletpassphrase before if you encrypted the wallet):

    dumpprivkey your_address

    Copy the result (do not share this with anyone, don’t post it here, for example)
    Back to blockchain.info
    If you already have a wallet there, just import the private key using the import feature (and pasting the result of the dumpprivkey command). If not, create a wallet before importing.
    From the blockchain wallet, send the coins to wherever you want.
    Once the unspent output is clear, you can remove the private key from blockchain wallet (you need to archive it first, I think).

    If that fails, please specify at which step it did, please.

    I’ve done all, when i get my private key i try to import this in a new wallet for example electrum then i get the error : The following inputs could not be imported “under this is show the private key”

    Electrum might not be the best choice, seedless wallets did not allow importing, last time I checked.
    Do you get the same error on a blockchain.info wallet?

    Error importing private key: TypeError: this.x is null

    How does that private key look like?

    Does it begin with 5 and have ~51 characters?

    I recommend you to go to [url]=https://www.bitaddress.org/]https://www.bitaddress.org/[url] choose tab “Wallet Details” and enter the private key you have.

    Check if you can decode it there. If you can, try importing to a blockchain.info wallet what you get under “Private Key WIF”.

    If it still fails, let us know in what step and with what output.

    Yes it start with a 5 an has 51 or 52 characters.

    I went to bitadress.org put in private key in wallet details.

    It says in private key wif all zero’s

    Then I think there was some error while exporting that private key.

    You should double check steps described by: Kouye

    Or try running this command before those described by him: walletpassphrase “your walletpassphrase here” 600

    Did I just find an old Hard Disk with 20BTC from 2012?

    I just found an old wallet on a recovered crashed drive from 2012 with almost 20BTC worth of unconfirmed satoshidice transactions. I looked them up in blockchain and there’s no record of them having occurred, with the client’s blockchain fully updated.

    Hate the break it to you: the 20 BTC in your wallet is undependable. the transactions have not confirmed since 2012 and are not in any client’s transaction list. unless they’re in a block, you can’t spend them.

    Why is the wallet qt software doing uploads to the network?

    Peer to Peer network trafic.

    When you are “downloading” the blockchain where do you think it is being “uploaded” from? The central Bitcoin, Inc server farm? Smiley

    That being said the QT client is pretty horrible about bandwidth management. Since devs seem to have no interest in putting in speed caps you may want to look into a third party tool which will cap the speed.

    How does the wallet qt program generate addresses and how do I know they are really random?

    It’s Open Source. this means the source code is not a secret and you can assume it is reviewed serveral times from different parties.


    any info about EC_KEY_regenerate_key(…) What is the seed that it gets? from where the random part. the pc is only pseudo random

    I guess the random part comes from the OpenSSL lib: #include

    How do you create a secure wallet?

    Sure ok. So ill give you a description of the most secure way to do it. Well go right to the james bond level.

    Hover over this url [url]=https://bitaddress.org]https://bitaddress.org[url] look in the bottom left corner of the screen to make sure it is honest
    Right click on that url and click save link as. Save it to a usb drive or something like that
    Boot ubuntu from your live cd (DO NOT CONNECT TO THE INTERNET)
    copy the bitaddress.org.htm file that you saved on your usb drive to your desktop
    open the bitaddress.org.htm file from your desktop
    go to the print paper wallet tab
    connect your pc to your printer using a usb cable and print the paper wallets (not wifi)
    (optional for extra security) clear your printer cache
    restart your computer
    send bitcoins to the address on your paper wallets in w/e denomination you like
    (recommended) laminate your paper wallets

    Can the Wallet QT, pay from specific address in coins

    Take a look at Armory. It acts as an extension of bitcoin-qt and has much better transaction control.

    What is Armory and does Feathercoin have Armory?

    Warning: Your computer’s date and time need to be correct.

    bitcoind / feathercoind, fail randomly, the correct PC time is required for operation…

    EXCEPTION: NSt8ios_base7failureE on ubuntu

    Delete data/blk*.dat and re-download the block chain

    PGP signature for release of Bitcoin QT

    • Open it in a text editor (like Notepad)
    • Select all of the text. Right click it. Copy.
    • Right click the Kleopatra icon in your system tray (lower right).
    • Choose Clipboard -> Decrypt/verify.
    • It will probably tell you that it’s not valid because it doesn’t know the public key. That’s a different issue…

    Recover wallet.dat on win 8.1

    The wallet.dat goes to %APPDATA%\Bitcoin\.

    Once there, you need to start bitcoin-qt with the flag -rescan.

    My recovered / restored wallet doesn’t work

    Check that is has been renamed correctly to wallet.dat.

    Someone made an unauthorized transaction from my wallet?

    I may have been hacked - someone has made a transcation of 1.2 something bitcoins from my wallet into theirs, essentially emptying my account.

    Nobody hacked your wallet. You did one of the following:

    Got a virus
    Use an online wallet
    Shared a private key
    Used a brain wallet

    Guarantee you you fit somewhere in those 4 options.

    I did indeed use an online wallet - blockchain.

    ALWAYS use a paperwallet if you are not trading BTC, but use it to wait to cash it out when the time is ripe. For buying stuff once in a while Save youre Wallet.dat or PC wallet on a harddisk/ USB drivenot connected to a pc on the web

    You can’t recover it. the money has been sent to the thief’s address and it can’t be reversed.

    Bitcoin: How to create a Bip0038 password protected paper wallet

    Fast speed video tutorial on creating super secure paper wallets:


    Is there a video on how to produce Feathercoin paper wallets.

    bitcoind / feathercoind problem error allocate memory.

    Either get more ram for your vps or increase the swap.

Log in to reply